Stream-Kompression: GZIP, BZIP2 & ZSTD
Einzeldatei-Stream-Kompressionsalgorithmen und Web-Transfer-Codecs.
Dateien werden lokal in Ihrem Browser mit WebAssembly- und HTML5-APIs verarbeitet. Sie verlassen niemals Ihr Gerät. Daher werden keine Dateien auf Server hochgeladen oder von Drittanbietern gespeichert.
Beginnen Sie sofort auf Ihrem eigenen Gerät mit der Konvertierung - ohne Wartezeit beim Upload, ohne Download-Warteschlange und ohne Drosselung durch einen externen Server.
Nutzen Sie jedes verfügbare Tool, ohne ein Konto anzulegen, einen Tarif zu bezahlen oder Dateigrößenbeschränkungen zu unterliegen. Konvertieren Sie so oft, wie es Ihr Browser und Gerät zulassen.
Formatvergleich & technische Spezifikationen
| Ausgabeformat | MIME-Typ | Spezifikation | Typ |
|---|---|---|---|
| GZ IP-Stream | application/gzip | RFC-1952-GZIP | GNU-Zip-DEFLATE-Stream |
| BR otli-Stream | application/x-brotli | RFC-7932-BROTLI | Brotli-Webkomprimierungsstream |
| ZST andard-Stream | application/zstd | RFC-8878-ZSTD | Echtzeit-Zstandard-Frame |
| DEFLATE Datenstrom ohne Header | application/octet-stream | RFC-1951-DEFLATE | Roher DEFLATE-Datenstrom |
| LZ4 Stream | application/x-lz4 | LZ4-FRAME-SPEC | Ultraschneller LZ4-Byte-Frame |
| GZ IP-Archiv | application/gzip | RFC-1952-GZIP | Mit DEFLATE komprimiertes Einzeldatei-Archiv |
| ZIP Archiv | application/zip | ISO-IEC-29500 | Standardmäßiges komprimiertes Archiv |
Technische Spezifikationen und Codec-Übersicht
Kompressions-Codecs im Vergleich zu Multi-Datei-Archiven
Ein weit verbreiteter Irrtum ist, dass GZIP (.gz) einer ZIP-Datei ähnelt. GZIP komprimiert lediglich eine einzelne Datei oder einen einzelnen Datenstrom. Um einen gesamten Ordner unter Linux zu komprimieren, fassen Werkzeuge den Ordner zunächst mit TAR zu einer einzigen Datei zusammen und komprimieren diese Datei anschließend mit GZIP (.tar.gz).
Zstandard (ZSTD): Einstellbare Komprimierung
Zstandard ist ein verlustfreies Komprimierungsformat mit einstellbarem Verhältnis zwischen Geschwindigkeit und Komprimierungsgrad. Der Durchsatz hängt von Daten, Stufe, Implementierung und Hardware ab; messen Sie den konkreten Workload.
0 Bytes an externe Server hochgeladen. Die gesamte Verarbeitung erfolgt lokal in Ihrer Browser-Sandbox.