Strømkomprimering: GZIP, BZIP2 & ZSTD
Algoritmer for komprimering av enkeltfiler og overføringskodeker for web.
Filer behandles lokalt i nettleseren din med WebAssembly og HTML5-API-er. De forlater aldri enheten din, så det er ingen serveropplastinger eller tredjeparts fillagring.
Start konverteringen umiddelbart på din egen enhet - ingen opplastingsventetid, ingen nedlastingskø og ingen hastighetsbegrensning fra en ekstern server.
Bruk alle tilgjengelige verktøy uten å opprette en konto, betale for et abonnement eller treffe en kunstig filstørrelsesgrense. Konverter så ofte som nettleseren og enheten din tåler.
Format-sammenligning og tekniske spesifikasjoner
| Utdataformat | MIME-type | Spesifikasjon | Type |
|---|---|---|---|
| GZ IP-strøm | application/gzip | RFC-1952-GZIP | GNU Zip DEFLATE-strøm |
| BR otli-strøm | application/x-brotli | RFC-7932-BROTLI | Brotli webkomprimeringsstrøm |
| ZST andard-strøm | application/zstd | RFC-8878-ZSTD | Zstandard-ramme for sanntidsbruk |
| DEFLATE Rå | application/octet-stream | RFC-1951-DEFLATE | Rå DEFLATE-strøm |
| LZ4 strøm | application/x-lz4 | LZ4-FRAME-SPEC | Ultrarask LZ4-ramme med bytestrøm |
| GZ IP-arkiv | application/gzip | RFC-1952-GZIP | DEFLATE-komprimert strøm |
| ZIP arkiv | application/zip | ISO-IEC-29500 | Standard ZIP-arkiv |
Tekniske spesifikasjoner og kodekoversikt
Komprimeringskodeker vs. flerfilsarkiver
En vanlig misforståelse er at GZIP (.gz) fungerer på samme måte som en ZIP-fil. GZIP komprimerer kun en enkelt fil eller strøm. For å komprimere en hel mappe i Linux, slår verktøyene først sammen mappen til en enkelt fil ved hjelp av TAR, og komprimerer deretter denne filen med GZIP (.tar.gz).
Zstandard (ZSTD): Konfigurerbar komprimering
Zstandard er et tapsfritt komprimeringsformat med justerbart kompromiss mellom hastighet og komprimeringsgrad. Gjennomstrømming avhenger av data, nivå, implementering og maskinvare; mål arbeidsbelastningen før du anslår ytelsen.
0 byte ble lastet opp til eksterne servere. All behandling foregikk lokalt i det isolerte nettlesermiljøet ditt.