Сертификати за сигурност: PEM, DER и PKCS#12
Base64 ASCII представяне, двоични DER сертификати и контейнери за частни ключове.
Файловете се обработват локално във вашия браузър с WebAssembly и HTML5 API. Те никога не напускат устройството ви, така че няма качвания на сървър или съхранение на файлове от трети страни.
Започнете да конвертирате веднага на собственото си устройство - без чакане за качване, без опашка за изтегляне и без ограничаване на скоростта от отдалечен сървър.
Използвайте всеки наличен инструмент, без да създавате акаунт, да плащате план или да достигате изкуствен лимит за размера на файловете. Конвертирайте толкова често, колкото браузърът и устройството ви позволяват.
Сравнение на формати и технически спецификации
| Изходен формат | MIME тип | Спецификация | Тип |
|---|---|---|---|
| PEM сертификат | application/x-pem-file | RFC-7468-PEM | Base64 защитен сертификат |
| CRT сертификат | application/x-x509-ca-cert | RFC-5280-X509 | X.509 публичен сертификат |
| CER сертификат | application/pkix-cert | RFC-5280-X509 | X.509 сертификат за сигурност |
| DER двоичен | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1 двоичен сертификат |
| P12 PKCS #12 пакет | application/x-pkcs12 | RFC-7292-PKCS12 | Шифрован архив на сертификати |
| PFX пакет | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft Personal Exchange архив |
Технически спецификации и анализ на кодеците
PEM срещу DER: текстов и двоичен формат
DER е двоичното ASN.1 кодиране на SSL/TLS сертификат. PEM е просто същите двоични данни, конвертирани в Base64 текст със заглавия '-----BEGIN CERTIFICATE-----', което позволява сертификатите да бъдат копирани и поставени в уеб сървъри и текстови конфигурации.
PKCS#12 (.pfx / .p12): Обединяване на ключ и сертификат
PEM сертификатът съдържа само публичния сертификат. При мигриране на сертификати между Windows сървъри или Java хранилища за ключове PKCS#12 пакетира публичния сертификат, пълната верига на доверие и криптирания частен ключ в един защитен с парола файл.
0 байта са качени на външни сървъри. Цялата обработка се извършва локално в пясъчниците на вашия браузър.