Компресиране на потоци: GZIP, BZIP2 и ZSTD
Алгоритми за компресия на потоци с един файл и кодеци за уеб трансфер.
Файловете се обработват локално във вашия браузър с WebAssembly и HTML5 API. Те никога не напускат устройството ви, така че няма качвания на сървър или съхранение на файлове от трети страни.
Започнете да конвертирате веднага на собственото си устройство - без чакане за качване, без опашка за изтегляне и без ограничаване на скоростта от отдалечен сървър.
Използвайте всеки наличен инструмент, без да създавате акаунт, да плащате план или да достигате изкуствен лимит за размера на файловете. Конвертирайте толкова често, колкото браузърът и устройството ви позволяват.
Сравнение на формати и технически спецификации
| Изходен формат | MIME тип | Спецификация | Тип |
|---|---|---|---|
| GZ IP поток | application/gzip | RFC-1952-GZIP | GNU Zip DEFLATE поток |
| BR otli поток | application/x-brotli | RFC-7932-BROTLI | Поток за уеб компресия Brotli |
| ZST andard поток | application/zstd | RFC-8878-ZSTD | Zstandard кадър в реално време |
| DEFLATE Суров | application/octet-stream | RFC-1951-DEFLATE | Суров поток DEFLATE |
| LZ4 поток | application/x-lz4 | LZ4-FRAME-SPEC | Ултра бърз LZ4 байтов кадър |
| GZ IP архив | application/gzip | RFC-1952-GZIP | Архив на един файл, компресиран с DEFLATE алгоритъм |
| ZIP архив | application/zip | ISO-IEC-29500 | Стандартен компресиран архив |
Технически спецификации и анализ на кодеците
Кодеци за компресия срещу многофайлови архиви
Често погрешно се смята, че GZIP (.gz) е като ZIP архив. GZIP компресира само един файл или поток. За да компресират цяла папка в Linux, инструментите първо обединяват съдържанието ѝ в един файл с TAR, а след това компресират този файл с GZIP (.tar.gz).
Zstandard (ZSTD): Настройки за компресия
Zstandard е формат за компресия без загуби с регулируем компромис между скорост и степен на компресия. Пропускателната способност зависи от данните, нивото, реализацията и хардуера; измерете конкретния товар.
0 байта са качени на външни сървъри. Цялата обработка се извършва локално в пясъчниците на вашия браузър.