Bezpečnostní certifikáty: PEM, DER a PKCS#12
Base64 ASCII kódování, binární certifikáty DER a kontejnery soukromých klíčů.
Soubory se zpracovávají lokálně ve vašem prohlížeči pomocí technologií WebAssembly a HTML5 API. Nikdy neopustí vaše zařízení, takže nedochází k nahrávání na server ani k ukládání souborů třetími stranami.
Začněte převádět okamžitě na svém vlastním zařízení - bez čekání na nahrání, fronty ke stažení a bez omezování rychlosti vzdáleným serverem.
Využívejte všechny dostupné nástroje bez nutnosti vytvářet účet, platit za předplatné nebo narážet na umělé limity velikosti souborů. Převádějte soubory tak často, jak to váš prohlížeč a zařízení zvládnou.
Porovnání formátů a technické specifikace
| Výstupní formát | MIME typ | Specifikace | Typ |
|---|---|---|---|
| PEM Certifikát | application/x-pem-file | RFC-7468-PEM | Certifikát zabezpečený kódováním Base64 |
| CRT Certifikát | application/x-x509-ca-cert | RFC-5280-X509 | Veřejný certifikát X.509 |
| CER tifikát | application/pkix-cert | RFC-5280-X509 | Bezpečnostní certifikát X.509 |
| DER Binární soubor | application/x-x509-ca-cert | RFC-5280-X509 | Binární certifikát ASN.1 |
| P12 Balíček PKCS #12 | application/x-pkcs12 | RFC-7292-PKCS12 | Šifrovaný archiv certifikátů |
| PFX Balíček | application/x-pkcs12 | RFC-7292-PKCS12 | Formát osobní výměny společnosti Microsoft |
Technické specifikace a přehled kodeků
PEM vs. DER: Text vs. Binární formát
DER je binární kódování ASN.1 SSL/TLS certifikátu. PEM jsou jednoduše tato přesná binární data převedená na text Base64 s hlavičkami '-----BEGIN CERTIFICATE-----', což umožňuje kopírování a vkládání certifikátů do webových serverů a textových konfiguračních souborů.
PKCS#12 (.pfx / .p12): Seskupení klíče a certifikátu
Certifikát PEM obsahuje pouze veřejný certifikát. Při migrování certifikátů mezi servery Windows nebo úložišti klíčů Java zabalí soubor PKCS#12 veřejný certifikát, celý řetěz důvěryhodnosti certifikátu a šifrovaný soukromý klíč do jediného souboru chráněného heslem.
0 bajtů odesláno na externí servery. Veškeré zpracování probíhalo lokálně v sandboxu vašeho prohlížeče.