Komprese streamů: GZIP, BZIP2 & ZSTD
Algoritmy pro kompresi jednosouborových streamů a kodeky pro webový přenos.
Soubory se zpracovávají lokálně ve vašem prohlížeči pomocí technologií WebAssembly a HTML5 API. Nikdy neopustí vaše zařízení, takže nedochází k nahrávání na server ani k ukládání souborů třetími stranami.
Začněte převádět okamžitě na svém vlastním zařízení - bez čekání na nahrání, fronty ke stažení a bez omezování rychlosti vzdáleným serverem.
Využívejte všechny dostupné nástroje bez nutnosti vytvářet účet, platit za předplatné nebo narážet na umělé limity velikosti souborů. Převádějte soubory tak často, jak to váš prohlížeč a zařízení zvládnou.
Porovnání formátů a technické specifikace
| Výstupní formát | MIME typ | Specifikace | Typ |
|---|---|---|---|
| GZ Proud GZIP | application/gzip | RFC-1952-GZIP | Kompresní proud GNU Zip DEFLATE |
| BR Proud Brotli | application/x-brotli | RFC-7932-BROTLI | Webový kompresní proud Brotli |
| ZST Proud Zstandard | application/zstd | RFC-8878-ZSTD | Rámec Zstandard pro reálný čas |
| DEFLATE Raw | application/octet-stream | RFC-1951-DEFLATE | Surový proud DEFLATE |
| LZ4 Proud | application/x-lz4 | LZ4-FRAME-SPEC | Ultrarychlý bajtový rámec LZ4 |
| GZ Archiv GZIP | application/gzip | RFC-1952-GZIP | Komprimovaný archiv pro jeden soubor pomocí DEFLATE |
| ZIP Archiv | application/zip | ISO-IEC-29500 | Standardní komprimovaný archiv |
Technické specifikace a přehled kodeků
Kompresní kodeky vs. Multi-file archivy
Častou mýlkou je, že formát GZIP (.gz) funguje stejně jako soubor ZIP. GZIP komprimuje pouze jediný soubor nebo stream. Pro kompresi celé složky v systému Linux nástroje nejprve sloučí složku do jednoho souboru pomocí nástroje TAR a následně tento soubor komprimují pomocí GZIP (.tar.gz).
Zstandard (ZSTD): Nastavitelná komprese
Zstandard je bezeztrátový kompresní formát s nastavitelným kompromisem mezi rychlostí a kompresním poměrem. Propustnost závisí na datech, úrovni, implementaci a hardwaru; před odhadem výkon změřte.
0 bajtů odesláno na externí servery. Veškeré zpracování probíhalo lokálně v sandboxu vašeho prohlížeče.