Sikkerhedscertifikater: PEM, DER & PKCS#12
Base64 ASCII-armering, binære DER-certifikater og private nøglebeholdere.
Filer behandles lokalt i din browser ved hjælp af WebAssembly og HTML5-API'er. De forlader aldrig din enhed, så der er ingen serverupload eller tredjeparts fillagring.
Start konverteringen med det samme på din egen enhed - ingen ventetid på upload, ingen downloadkø og ingen begrænsning fra en ekstern server.
Brug alle tilgængelige værktøjer uden at oprette en konto, betale for et abonnement eller støde på en kunstig filstørrelsesgrænse. Konverter så ofte din browser og enhed kan klare det.
Formatsammenligning & tekniske specifikationer
| Outputformat | MIME-type | Specifikation | Type |
|---|---|---|---|
| PEM certifikat | application/x-pem-file | RFC-7468-PEM | Base64-kodet certifikat |
| CRT certifikat | application/x-x509-ca-cert | RFC-5280-X509 | X.509-offentligt certifikat |
| CER certifikat | application/pkix-cert | RFC-5280-X509 | X.509-sikkerhedscertifikat |
| DER binær | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1-binært certifikat |
| P12 PKCS #12-bundt | application/x-pkcs12 | RFC-7292-PKCS12 | Krypteret certifikatarkiv |
| PFX pakke | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft Personal Exchange-pakke |
Tekniske specifikationer og codec-oversigt
PEM vs. DER: Tekst vs. Binær
DER er den binære ASN.1-kodning af et SSL/TLS-certifikat. PEM er simpelthen netop disse binære data konverteret til Base64-tekst med '-----BEGIN CERTIFICATE-----' headere, hvilket gør det muligt at kopiere og indsætte certifikater i webservere og tekstkonfigurationer.
PKCS#12 (.pfx / .p12): Bundtning af nøgle og certifikat
Et PEM-certifikat indeholder kun det offentlige certifikat. Ved migrering af certifikater mellem Windows-servere eller Java-nøglelager (keystores) pakker PKCS#12 det offentlige certifikat, hele certifikatets tillidskæde (trust chain) og den krypterede private nøgle ind i en enkelt adgangskodebeskyttet fil.
0 byte overført til eksterne servere. Al behandling foregik lokalt i browserens sandkasse.