Μετατροπή MBOX σε EML
Η μετατροπή ενός αρχείου MBOX σε ξεχωριστά αρχεία EML χωρίζει μια τεράστια ενοποιημένη βάση δεδομένων email σε μεμονωμένα, τυπικά έγγραφα μηνυμάτων.
Σύγκριση μορφών και τεχνικές προδιαγραφές
| Προδιαγραφή | MBOX | EML |
|---|---|---|
| Τύπος MIME | application/ | message/ |
| Τύπος | Αρχείο συνένωσης γραμματοκιβωτίων email | Τυπικό αρχείο μηνύματος email |
| Συμπίεση | κανένα (συνένωση κειμένου) | κανένα (κωδικοποίηση MIME multipart) |
| Πρότυπη προδιαγραφή | IETF RFC 4155 | IETF RFC 5322 |
| Κεφαλίδα Magic Bytes | 46 72 6F 6D 20 (From separator line) | From: / Received: / Return-Path: (RFC 822/5322 header lines) |
Επισκόπηση Μορφής & Εφαρμογές
Το MBOX μπορεί να αποθηκεύσει πολλά μηνύματα σε ένα αρχείο, ενώ το EML αποθηκεύει μεμονωμένα μηνύματα. Ο διαχωρισμός ενός αρχείου MBOX μπορεί να βοηθήσει όταν ο παραλήπτης χρειάζεται ξεχωριστά αρχεία μηνυμάτων, αλλά η υποστήριξη των προγραμμάτων αλληλογραφίας, το μέγεθος του αρχείου και ο χρόνος επεξεργασίας εξαρτώνται από την εφαρμογή και τον αριθμό των μηνυμάτων. Ελέγξτε τα μηνύματα και τα συνημμένα που εξήχθησαν πριν βασιστείτε σε αυτά ως αρχείο ή επίσημο αντίγραφο.
Τεχνικές προδιαγραφές και ανάλυση κωδικοποιητών
Ένα αρχείο MBOX (application/mbox) είναι ένα κοντέινερ συγχώνευσης απλού κειμένου που συνδέει πολλαπλά μηνύματα email διαδοχικά. Χρησιμοποιεί την κεφαλίδα γραμμής From - ως αυστηρό διαχωριστικό για να επισημάνει πού τελειώνει ένα μήνυμα και πού ξεκινά το επόμενο. Η συμπίεση αρχείου είναι ανύπαρκτη, πράγμα που σημαίνει ότι το ακατέργαστο κείμενο ρέει συνεχώς. Αντίθετα, ένα αρχείο EML χρησιμοποιεί τον τύπο MIME message/rfc822 για να αποθηκεύσει ένα μόνο μήνυμα email πλήρες με κωδικοποίηση MIME multipart για συνημμένα και σώματα HTML. Κατά τη διάρκεια της μετατροπής, ένας αναλυτής διαβάζει τη ροή MBOX, εντοπίζει τα όρια From -, εξάγει κάθε ξεχωριστό μπλοκ κειμένου και το αποθηκεύει με την επέκταση .eml. Αυτή η διαδικασία είναι αυστηρά χωρίς απώλειες επειδή και οι δύο μορφές βασίζονται σε τυπικούς κανόνες μορφής μηνυμάτων διαδικτύου που ορίζονται στα πρότυπα RFC 5322 και RFC 822, πράγμα που σημαίνει ότι κανένα κείμενο ή δεδομένα δυαδικών συνημμένων δεν αλλοιώνονται ή συμπιέζονται.
Συμβατότητα Λειτουργικού Συστήματος & Προγράμματος Περιήγησης
Το MBOX συνήθως αποθηκεύει ένα γραμματοκιβώτιο ως ένα αρχείο που περιέχει πολλά μηνύματα· το EML αποθηκεύει κάθε μήνυμα ξεχωριστά. Το Thunderbird και άλλα προγράμματα αλληλογραφίας μπορούν να εισαγάγουν MBOX, ενώ τα αρχεία EML μπορούν να ανοιχτούν ή να εισαχθούν μεμονωμένα. Ελέγξτε τα συνημμένα και τις ημερομηνίες μετά την εξαγωγή, πριν χρησιμοποιήσετε τα αρχεία ως αρχειοθήκη.
Χρήσιμες πληροφορίες
Διατηρήστε αντίγραφα ασφαλείας των αρχικών σας αρχείων MBOX προτού τα χωρίσετε σε αρχεία EML, καθώς η επεξεργασία δεκάδων χιλιάδων μεμονωμένων μηνυμάτων μπορεί να γεμίσει τους φακέλους προορισμού και να επιβαρύνει τα παλαιότερα συστήματα αρχείων.
Συχνές Ερωτήσεις
Πώς μετατρέπεται το αρχείο MBOX σε EML RFC 822 χωρίς απώλεια ποιότητας;
Η μετατροπή μπορεί να διατηρήσει μηνύματα και συνημμένα, αλλά το αποτέλεσμα εξαρτάται από το λογισμικό και τον χειρισμό των διαχωριστικών MBOX. Ελέγξτε το αποτέλεσμα.
Ποια είναι η διαφορά μεταξύ του αρχείου MBOX και του email RFC 822;
Ένα αρχείο MBOX λειτουργεί ως ενιαίο δοχείο που φιλοξενεί πολλά συγχωνευμένα email χωρισμένα με δείκτες κειμένου. Ένα αρχείο EML είναι ένα αυτόνομο αρχείο που περιέχει μόνο ένα μεμονωμένο μήνυμα email ακολουθώντας τα πρότυπα RFC 822 και RFC 5322.