Αρχεία Email: Δομές EML, MSG & MBOX
Όρια μηνυμάτων MIME, κεφαλίδες email και μετεγκαταστάσεις μεταξύ προγραμμάτων-πελατών.
Τα αρχεία επεξεργάζονται τοπικά στον περιηγητή σας χρησιμοποιώντας WebAssembly και HTML5 APIs. Δεν φεύγουν ποτέ από τη συσκευή σας, επομένως δεν υπάρχουν μεταφορτώσεις σε διακομιστή ούτε αποθήκευση αρχείων από τρίτους.
Ξεκινήστε τη μετατροπή αμέσως στη δική σας συσκευή - χωρίς αναμονή μεταφόρτωσης, χωρίς ουρά λήψης και χωρίς περιορισμούς από απομακρυσμένο διακομιστή.
Χρησιμοποιήστε κάθε διαθέσιμο εργαλείο χωρίς να δημιουργήσετε λογαριασμό, να πληρώσετε συνδρομή ή να συναντήσετε τεχνητά όρια μεγέθους αρχείου. Μετατρέψτε όσο συχνά αντέχουν ο περιηγητής και η συσκευή σας.
Σύγκριση μορφών και τεχνικές προδιαγραφές
| Μορφή Εξόδου | Τύπος MIME | Προδιαγραφή | Τύπος |
|---|---|---|---|
| EML Email RFC 822 | message/rfc822 | RFC-5322-EMAIL | Τυπικό αρχείο μηνύματος ηλεκτρονικού ταχυδρομείου |
| MSG Outlook | application/vnd.ms-outlook | MS-OXMSG-SPEC | Αντικείμενο Microsoft Outlook |
| MBOX Αρχείο | application/mbox | RFC-5322-EMAIL | Αρχείο συγχώνευσης γραμματοκιβωτίου |
| VCF Επαφή vCard | text/vcard | RFC-6350-VCARD | Ηλεκτρονική επαγγελματική κάρτα |
| ICS iCalendar | text/calendar | RFC-5545-ICAL | Εκδήλωση ημερολογίου και προγραμματισμού |
| PDF Έγγραφο | application/pdf | ISO-32000-2 | Φορητή μορφή εγγράφου |
| HTML Έγγραφο | text/html | RFC-5322-EMAIL | Έγγραφο υπερκειμένου HyperText Markup |
| TXT Απλό κείμενο | text/plain | RFC-4180-CSV | Απλό κείμενο χωρίς μορφοποίηση |
| CSV Πίνακας | text/csv | RFC-4180-CSV | Τιμές διαχωρισμένες με κόμμα |
Τεχνικές προδιαγραφές και ανάλυση κωδικοποιητών
EML έναντι MSG: Το Ανοιχτό Πρότυπο έναντι του Outlook
Το EML αποθηκεύει συνήθως μηνύματα με το Internet Message Format και τις συμβάσεις MIME, ενώ τα προγράμματα email μπορεί να χρησιμοποιούν και δικές τους μορφές αποθήκευσης. Το MSG είναι μορφή μηνυμάτων του Microsoft Outlook. Η μετατροπή MSG σε EML μπορεί να διευκολύνει το άνοιγμα σε άλλο λογισμικό, αλλά η εμφάνιση και η υποστήριξη μεταδεδομένων διαφέρουν ανά εφαρμογή.
Εξαγωγή Συνημμένων & Διατήρηση Κεφαλίδων
Ένα email μπορεί να περιλαμβάνει κεφαλίδες μηνύματος, τμήματα MIME και συνημμένα. Η εξαγωγή EML σε PDF μπορεί να δημιουργήσει ευανάγνωστο αντίγραφο, αλλά δεν διατηρεί από μόνη της ολόκληρη την αρχική δομή ούτε αποδεικνύει γνησιότητα ή νομική ελεγξιμότητα. Κρατήστε το αρχικό μήνυμα και ακολουθήστε τις απαιτήσεις τήρησης αρχείων της ροής εργασίας σας.
Δεν μεταφορτώνεται κανένα byte σε εξωτερικούς διακομιστές. Όλη η επεξεργασία γίνεται τοπικά στο απομονωμένο περιβάλλον του προγράμματος περιήγησής σας.