Πιστοποιητικά Ασφαλείας: PEM, DER & PKCS#12
Base64 ASCII θωράκιση, δυαδικά πιστοποιητικά DER και δοχεία ιδιωτικών κλειδιών.
Τα αρχεία επεξεργάζονται τοπικά στον περιηγητή σας χρησιμοποιώντας WebAssembly και HTML5 APIs. Δεν φεύγουν ποτέ από τη συσκευή σας, επομένως δεν υπάρχουν μεταφορτώσεις σε διακομιστή ούτε αποθήκευση αρχείων από τρίτους.
Ξεκινήστε τη μετατροπή αμέσως στη δική σας συσκευή - χωρίς αναμονή μεταφόρτωσης, χωρίς ουρά λήψης και χωρίς περιορισμούς από απομακρυσμένο διακομιστή.
Χρησιμοποιήστε κάθε διαθέσιμο εργαλείο χωρίς να δημιουργήσετε λογαριασμό, να πληρώσετε συνδρομή ή να συναντήσετε τεχνητά όρια μεγέθους αρχείου. Μετατρέψτε όσο συχνά αντέχουν ο περιηγητής και η συσκευή σας.
Σύγκριση μορφών και τεχνικές προδιαγραφές
| Μορφή Εξόδου | Τύπος MIME | Προδιαγραφή | Τύπος |
|---|---|---|---|
| PEM Πιστοποιητικό | application/x-pem-file | RFC-7468-PEM | Πιστοποιητικό προστατευμένο με Base64 |
| CRT Πιστοποιητικό | application/x-x509-ca-cert | RFC-5280-X509 | Δημόσιο πιστοποιητικό X.509 |
| CER Πιστοποιητικό | application/pkix-cert | RFC-5280-X509 | Πιστοποιητικό ασφαλείας X.509 |
| DER Δυαδικό | application/x-x509-ca-cert | RFC-5280-X509 | Δυαδικό πιστοποιητικό ASN.1 |
| P12 Πακέτο PKCS #12 | application/x-pkcs12 | RFC-7292-PKCS12 | Κρυπτογραφημένο αρχείο πιστοποιητικών |
| PFX Πακέτο | application/x-pkcs12 | RFC-7292-PKCS12 | Αρχείο ανταλλαγής προσωπικών δεδομένων Microsoft |
Τεχνικές προδιαγραφές και ανάλυση κωδικοποιητών
PEM έναντι DER: Κείμενο έναντι Δυαδικού
Το DER είναι η δυαδική κωδικοποίηση ASN.1 ενός πιστοποιητικού SSL/TLS. Το PEM είναι απλώς αυτά τα ακριβή δυαδικά δεδομένα μετατραπέντα σε κείμενο Base64 με κεφαλίδες '-----BEGIN CERTIFICATE-----', επιτρέποντας στα πιστοποιητικά να αντιγράφονται-επικολλώνται σε διακομιστές ιστού και αρχεία ρυθμίσεων κειμένου.
PKCS#12 (.pfx / .p12): Ομαδοποίηση Κλειδιού και Πιστοποιητικού
Ένα πιστοποιητικό PEM περιέχει μόνο το δημόσιο πιστοποιητικό. Κατά τη μετεγκατάσταση πιστοποιητικών μεταξύ διακομιστών Windows ή αποθηκών κλειδιών Java, το PKCS#12 συσκευάζει το δημόσιο πιστοποιητικό, την πλήρη αλυσίδα εμπιστοσύνης πιστοποιητικών και το κρυπτογραφημένο ιδιωτικό κλειδί σε ένα ενιαίο αρχείο προστατευμένο με κωδικό πρόσβασης.
Δεν μεταφορτώνεται κανένα byte σε εξωτερικούς διακομιστές. Όλη η επεξεργασία γίνεται τοπικά στο απομονωμένο περιβάλλον του προγράμματος περιήγησής σας.