Συμπίεση Ροής: GZIP, BZIP2 & ZSTD
Αλγόριθμοι συμπίεσης ροής ενός αρχείου και κωδικοποιητές μεταφοράς στον ιστό.
Τα αρχεία επεξεργάζονται τοπικά στον περιηγητή σας χρησιμοποιώντας WebAssembly και HTML5 APIs. Δεν φεύγουν ποτέ από τη συσκευή σας, επομένως δεν υπάρχουν μεταφορτώσεις σε διακομιστή ούτε αποθήκευση αρχείων από τρίτους.
Ξεκινήστε τη μετατροπή αμέσως στη δική σας συσκευή - χωρίς αναμονή μεταφόρτωσης, χωρίς ουρά λήψης και χωρίς περιορισμούς από απομακρυσμένο διακομιστή.
Χρησιμοποιήστε κάθε διαθέσιμο εργαλείο χωρίς να δημιουργήσετε λογαριασμό, να πληρώσετε συνδρομή ή να συναντήσετε τεχνητά όρια μεγέθους αρχείου. Μετατρέψτε όσο συχνά αντέχουν ο περιηγητής και η συσκευή σας.
Σύγκριση μορφών και τεχνικές προδιαγραφές
| Μορφή Εξόδου | Τύπος MIME | Προδιαγραφή | Τύπος |
|---|---|---|---|
| GZ Ροή GZIP | application/gzip | RFC-1952-GZIP | Ροή συμπίεσης GNU Zip DEFLATE |
| BR Ροή Brotli | application/x-brotli | RFC-7932-BROTLI | Ροή συμπίεσης ιστού Brotli |
| ZST Ροή Zstandard | application/zstd | RFC-8878-ZSTD | Πλαίσιο πραγματικού χρόνου Zstandard |
| DEFLATE Raw | application/octet-stream | RFC-1951-DEFLATE | Ακατέργαστη ροή DEFLATE |
| LZ4 Ροή | application/x-lz4 | LZ4-FRAME-SPEC | Εξαιρετικά γρήγορο πλαίσιο byte LZ4 |
| GZ Αρχειοθήκη GZIP | application/gzip | RFC-1952-GZIP | Συμπιεσμένη αρχειοθήκη ενός αρχείου DEFLATE |
| ZIP Αρχειοθήκη | application/zip | ISO-IEC-29500 | Τυπική συμπιεσμένη αρχειοθήκη |
Τεχνικές προδιαγραφές και ανάλυση κωδικοποιητών
Κωδικοποιητές Συμπίεσης έναντι Αρχειοθηκών Πολλαπλών Αρχείων
Μια συνηθισμένη παρανόηση είναι ότι το GZIP (.gz) είναι σαν ένα αρχείο ZIP. Το GZIP συμπιέζει μόνο ένα μεμονωμένο αρχείο ή ροή. Για να συμπιεσθεί ένας ολόκληρος φάκελος σε Linux, τα εργαλεία συνδυάζουν αρχικά τον φάκελο σε ένα ενιαίο αρχείο με TAR και στη συνέχεια συμπιέζουν αυτό το αρχείο με GZIP (.tar.gz).
Zstandard (ZSTD): Ρυθμιζόμενη συμπίεση
Το Zstandard είναι μορφή συμπίεσης χωρίς απώλειες με ρυθμιζόμενη ισορροπία ταχύτητας και λόγου συμπίεσης. Η απόδοση εξαρτάται από τα δεδομένα, το επίπεδο, την υλοποίηση και το υλικό· μετρήστε τον φόρτο εργασίας.
Δεν μεταφορτώνεται κανένα byte σε εξωτερικούς διακομιστές. Όλη η επεξεργασία γίνεται τοπικά στο απομονωμένο περιβάλλον του προγράμματος περιήγησής σας.