Tietoturvavarmenteet: PEM, DER ja PKCS#12
Base64-merkkijonokoodaus, binäärimuotoiset DER-varmenteet ja yksityisen avaimen säiliöt.
Tiedostot käsitellään paikallisesti selaimessasi WebAssembly- ja HTML5-rajapintojen avulla. Ne eivät poistu laitteeltasi, joten niitä ei ladata palvelimille eikä tallenneta kolmansien osapuolten palveluihin.
Aloita muuntaminen välittömästi omalla laitteellasi - ei latausodotusta, ei latausjonoja eikä etäpalvelimen asettamia hidastuksia.
Käytä kaikkia työkaluja ilman tilin luomista, maksullista tilausta tai keinotekoisia tiedostokokorajoituksia. Muunna tiedostoja niin usein kuin selaimesi ja laitteesi sallivat.
Muotojen vertailu ja tekniset tiedot
| Tulostusmuoto | MIME-tyyppi | Määritys | Tyyppi |
|---|---|---|---|
| PEM varmente | application/x-pem-file | RFC-7468-PEM | Base64-suojattu varmenne |
| CRT varmenne | application/x-x509-ca-cert | RFC-5280-X509 | X.509-julkinen varmenne |
| CER varmenne | application/pkix-cert | RFC-5280-X509 | X.509-turvavarmenne |
| DER binääri | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1-binäärivarmenne |
| P12 PKCS #12 -paketti | application/x-pkcs12 | RFC-7292-PKCS12 | Salattu varmennearkisto |
| PFX paketti | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft Personal Exchange -paketti |
Tekniset tiedot ja koodekkien erittely
PEM vs. DER: Teksti vs. Binääri
DER on SSL/TLS-varmenteen binäärimuotoinen ASN.1-koodaus. PEM puolestaan on sama binääridata muunnettuna Base64-tekstiksi, jossa on "-----BEGIN CERTIFICATE-----" -otsikot. Tämän ansiosta varmenteet voidaan kopioida suoraan verkkopalvelimiin ja tekstitiedostomuotoisiin asetuksiin.
PKCS#12 (.pfx / .p12): Avaimen ja varmenteen niputtaminen
PEM-varmenne sisältää ainoastaan julkisen varmenteen. Siirrettäessä varmenteita Windows-palvelinten tai Java-avainsäilöjen välillä PKCS#12 pakkaa julkisen varmenteen, koko varmenteen luottamusketjun ja salatun yksityisen avaimen yhteen ainoaan salasanasuojattuun tiedostoon.
Ulkoisille palvelimille ei ole ladattu yhtään tavua. Kaikki käsittely tapahtui paikallisesti selaimen hiekkalaatikossa.