Tekniset standardit ja viralliset lähteet

Viralliset standardit, RFC:t ja muotomääritykset, joihin File2File.app viittaa.

Viimeksi päivitetty: syyskuu 2026

Standardointijärjestöjen rekisteri

Jokainen File2File.app-palvelun muunnosääntö, MIME-tyyppi ja taikatavumääritys perustuu kansainvälisten järjestöjen julkaisemiin virallisiin standardeihin:

ISO 32000-2:2020 Asiakirjanhallinta - Kannettava dokumenttimuoto - Osa 2: PDF 2.0

International Organization for Standardization

Näytä määrityksen linkki →

ISO/IEC 29500-1:2016 Tietotekniikka - Dokumentin kuvaus- ja käsittelykielet - Office Open XML -tiedostomuodot

ISO/IEC JTC 1/SC 34

Näytä määrityksen linkki →

Portable Network Graphics (PNG) -määrittely (kolmas painos)

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

Scalable Vector Graphics (SVG) 2 -määrittely

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

ITU-T-suositus T.81 / ISO/IEC 10918-1: Tietotekniikka - Jatkuvasävyisten kuvien digitaalinen pakkaus ja koodaus

Kansainvälinen televiestintäliitto

Näytä määrityksen linkki →

RFC 6386: VP8-tietomuoto ja dekoodausopas (WebP Core)

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

ISO/IEC 23008-12:2024 tehokas kuvatiedostomuoto (HEIF)

International Organization for Standardization

Näytä määrityksen linkki →

AV1 Image File Format (AVIF) -määrittely v1.1.0

Alliance for Open Media

Näytä määrityksen linkki →

RFC 5334: Ogg-mediatyypit ja säiliömäärittely

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 6716: Opus-audiokoodekin määrittely

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

ISO/IEC 14496-14:2020 Tietotekniikka - Audiovisuaalisten kohteiden koodaus - Osa 14: MP4-tiedostomuoto

International Organization for Standardization

Näytä määrityksen linkki →

EPUB 3.3 -määrittely

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

WOFF-tiedostomuoto 2.0 -määrittely

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

AutoCAD Drawing Exchange Format (DXF) -viite

Autodesk Developer Network

Näytä määrityksen linkki →

RFC 4180: Yleinen muoto ja MIME-tyyppi pilkuilla erotetuille arvoille (CSV) -tiedostoille

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

POSIX.1-2017 / IEEE Std 1003.1: Tietotekniikan standardi - Laajennettu TAR-arkistomuoto

IEEE & The Open Group

Näytä määrityksen linkki →

RFC 1952: GZIP-tiedostomuodon määrittely versio 4.3

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

7z-arkistomuodon määrittely ja LZMA SDK

7-Zip / Igor Pavlov

Näytä määrityksen linkki →

bzip2- ja libbzip2-pakkausohjelmien määrittely

Julian Seward / Sourceware

Näytä määrityksen linkki →

RAR 5.0 -arkistotiedoston muodon tekninen määrittely

Eugene Roshal / Win.rar GmbH

Näytä määrityksen linkki →

ISO 9660:1988 Tiedonkäsittely - CD-ROM-levyjen taltio- ja tiedostorakenne tiedonvaihtoa varten

International Organization for Standardization

Näytä määrityksen linkki →

Virtuaalikoneen levyn (VMDK) muotomäärittely versio 5.0

VMware / Broadcom

Näytä määrityksen linkki →

Virtuaalisen kiintolevyn (VHD) levykuvatiedostomuodon määrittely

Microsoft Corporation

Näytä määrityksen linkki →

Apple Disk Image (DMG) -universaalin levykuvamuodon määrittely

Apple Inc.

Näytä määrityksen linkki →

Mobipocket-tiedostomuodon määrittely ja avoin pakkausrakenne

Mobipocket / Amazon

Näytä määrityksen linkki →

Amazon Kindle Format 8 (AZW3) -julkaisuohjeet

Amazon Kindle Direct Publishing

Näytä määrityksen linkki →

FictionBook 2.0 (FB2) -XML-e-kirjamäärittely

FictionBook Open Source Project

Näytä määrityksen linkki →

WebVTT: Web-videotekstitysraitojen muoto

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

Matroska / SubRip -tekstitysmuodon määrittely (SRT)

Matroska Specification Project

Näytä määrityksen linkki →

Advanced SubStation Alpha v4.00+ -skriptimuodon määrittely

Doom9 / Aegisub Community

Näytä määrityksen linkki →

Khronos glTF 2.0 -määrittely (GL Transmission Format)

Khronos Group 3D Formats Working Group

Näytä määrityksen linkki →

Polygon File Format (PLY) -määrittely

Stanford University Computer Graphics Laboratory

Näytä määrityksen linkki →

Autodesk FBX SDK ja binääriomaisuuden määrittely

Autodesk Developer Network

Näytä määrityksen linkki →

SQLite-tietokantatiedoston muoto

SQLite Development Team

Näytä määrityksen linkki →

ISO/IEC 9075: Tietotekniikka - Tietokantakielet - SQL

International Organization for Standardization

Näytä määrityksen linkki →

TIFF Revision 6.0 -määrittely

Adobe Systems Incorporated

Näytä määrityksen linkki →

Microsoft Windows Bitmap (BMP) -tiedostomuodon määrittely

Microsoft Developer Network

Näytä määrityksen linkki →

Truevision TGA -tiedostomuodon määrittely versio 2.0

Truevision / AT&T

Näytä määrityksen linkki →

Microsoft DirectDraw Surface (DDS) -ohjelmointiopas ja muotomäärittely

Microsoft DirectX Graphics Documentation

Näytä määrityksen linkki →

Adobe Digital Negative (DNG) -määrittely versio 1.6.0.0

Adobe Systems Incorporated

Näytä määrityksen linkki →

Canon-digikameran RAW-tiedostomuodon määrittely (CR2)

Canon Inc. / ExifTool Metadata Project

Näytä määrityksen linkki →

Nikon Electronic Format (NEF) -tekninen viite

Nikon Corporation / LibRaw Project

Näytä määrityksen linkki →

Sony Alpha RAW (ARW) -määrittely ja metatietoviite

Sony Corporation / ExifTool Project

Näytä määrityksen linkki →

RFC 4648: Base16-, Base32- ja Base64-datakoodaukset

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

Heksadesimaalisen objektitiedoston muodon määrittely (Intel HEX)

Intel Corporation

Näytä määrityksen linkki →

RFC 7946: GeoJSON-muoto

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

OGC KML 2.3 -standardimäärittely

Open Geospatial Consortium (OGC)

Näytä määrityksen linkki →

GPX: GPS Exchange Format 1.1 -skeema

Topografix

Näytä määrityksen linkki →

ESRI Shapefile -tekninen taustajulkaisu

Environmental Systems Research Institute (ESRI)

Näytä määrityksen linkki →

Adobe Swatch Exchange (ASE) -tiedostomuodon määrittely

Adobe Systems Developer Support

Näytä määrityksen linkki →

GIMP Palette (GPL) -muodon dokumentaatio

GNU Image Manipulation Program (GIMP) Project

Näytä määrityksen linkki →

CSS Color Module Level 4 -määrittely

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

YAML Ain't Markup Language (YAML) versio 1.2 -määrittely

YAML.org Working Group

Näytä määrityksen linkki →

TOML: Tom's Obvious Minimal Language -määrittely v1.0.0

TOML Open Source Project

Näytä määrityksen linkki →

Extensible Markup Language (XML) 1.0 (viides painos)

World Wide Web Consortium (W3C)

Näytä määrityksen linkki →

Flexible Image Transport System (FITS) -standardin 4.0 määrittely

International Astronomical Union (IAU) FITS Working Group

Näytä määrityksen linkki →

HDF5-tiedostomuodon määrittely versio 3.0

The HDF Group

Näytä määrityksen linkki →

NetCDF-tiedostorakenteen ja -muodon määrittely

UCAR Unidata Program Center

Näytä määrityksen linkki →

NCBI FASTA -sekvenssiesitys ja Blast-tietokantamuoto

National Center for Biotechnology Information (NCBI)

Näytä määrityksen linkki →

Protein Data Bank -sisältöopas: Atomikoordinaattien syöttömuodon kuvaus v3.30

Worldwide Protein Data Bank (wwPDB)

Näytä määrityksen linkki →

RFC 7932: Brotli-pakatun datan muoto

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 8878: Zstandard-pakkaus ja 'application/zstd'-tyyppi

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 1951: DEFLATE-pakatun tietomuodon määrittely versio 1.3

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

LZ4-kehyksen muodon kuvaus

Yann Collet / LZ4 Project

Näytä määrityksen linkki →

RFC 7468: PKIX-, PKCS- ja CMS-rakenteiden tekstikoodaukset (PEM)

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 5280: Internet X.509 -julkisen avaimen infrastruktuurin varmenneprofiili

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 7292: PKCS #12: Henkilökohtaisten tietojen vaihdon syntaksi v1.1

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 5322: Internet-viestimuoto

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 6350: vCard-muodon määrittely (vCard v4.0)

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

RFC 5545: Internetin kalenteröinti- ja ajoitusobjektin määrittely (iCalendar)

Internet Engineering Task Force (IETF)

Näytä määrityksen linkki →

MS-OXMSG: Outlook-kohteen (.msg) tiedostomuoto

Microsoft Corporation

Näytä määrityksen linkki →

QEMU Copy-On-Write Image Format (QCOW2) -määrittely

QEMU Open Source Project

Näytä määrityksen linkki →

Microsoft SQL Serverin varmuuskopion ja palautuksen tekninen arkkitehtuuri

Microsoft Corporation

Näytä määrityksen linkki →

hOCR 1.2 -muotomäärittely (OCR-esitysstandardi)

hOCR Specification Working Group

Näytä määrityksen linkki →

Tesseract Open Source OCR -moottorin arkkitehtuuri ja sivun asettelun analyysi

Tesseract OCR Open Source Project / Google

Näytä määrityksen linkki →

APNG (Animated Portable Network Graphics) -määrittely

Mozilla Developer Network (MDN) / W3C

Näytä määrityksen linkki →

Lottie-animaatiomuodon määrittely

LottieFiles / Airbnb

Näytä määrityksen linkki →

ISO/IEC 14496-3: Tietotekniikka - Audiovisuaalisten kohteiden koodaus - Osa 3: Ääni (AAC)

ISO/IEC JTC 1/SC 29

Näytä määrityksen linkki →

Free Lossless Audio Codec (FLAC) -muotomäärittely

Xiph.Org Foundation

Näytä määrityksen linkki →

Apple Lossless Audio Codec (ALAC) -avoimen lähdekoodin määrittely

Apple Inc.

Näytä määrityksen linkki →

Audio Interchange File Format (AIFF) -määrittely v1.3

Apple Computer, Inc.

Näytä määrityksen linkki →

Direct Stream Digital (DSD / DSF) -audiomuodon määrittely

Sony Corporation / Philips

Näytä määrityksen linkki →

Monkey's Audio (.ape) -häviöttömän audiomuodon määrittely

Monkey's Audio / Matthew T. Ashland

Näytä määrityksen linkki →

[MS-EMF]: Enhanced Metafile Format

Microsoft Corporation

Näytä määrityksen linkki →

[MS-WMF]: Windows Metafile Format

Microsoft Corporation

Näytä määrityksen linkki →

Adobe Photoshop File Formats Specification

Adobe Systems Inc.

Näytä määrityksen linkki →

Canon Camera Image File Format (CIFF) Specification (CRW)

Canon Inc. / ExifTool Project

Näytä määrityksen linkki →

Canon Digital Camera RAW File Format Specification (CR3 / CRX ISOBMFF)

Canon Inc. / ExifTool Metadata Project

Näytä määrityksen linkki →

Fujifilm RAW Format (RAF) Technical Specification

Fujifilm Corporation / ExifTool Project

Näytä määrityksen linkki →

Kodak Professional Digital Camera RAW Formats Reference (DCR / KDC / K25)

Eastman Kodak Company / ExifTool Project

Näytä määrityksen linkki →

Leica Camera RAW -muodon (RWL / DNG) tekninen viiteasiakirja

Leica Camera AG / ExifTool Project

Näytä määrityksen linkki →

LibRaw RAW -kuvamuotojen kuvaus ja tuetut kamerat

LibRaw LLC

Näytä määrityksen linkki →

Olympus / OM Digital Solutions RAW -muodon (ORF) tekninen viiteasiakirja

OM Digital Solutions / ExifTool Project

Näytä määrityksen linkki →

Panasonic Lumix RAW (RW2) -muodon tekninen viiteasiakirja

Panasonic Corporation / ExifTool Project

Näytä määrityksen linkki →

Pentax Electronic File (PEF / PTX) -muodon viiteasiakirja

Ricoh Imaging Company / ExifTool Project

Näytä määrityksen linkki →

QuickTime-tiedostomuodon määrittely

Apple Inc.

Näytä määrityksen linkki →

Samsung NX RAW -muodon (SRW) tekninen viiteasiakirja

Samsung Electronics / ExifTool Project

Näytä määrityksen linkki →

Sigma Foveon X3 Direct Image Sensor RAW Format (X3F)

Sigma Corporation / ExifTool Project

Näytä määrityksen linkki →

Truevision Targa -tiedostomuodon määrittely versio 2.0

Truevision Inc.

Näytä määrityksen linkki →

ZSoft Corporation Paintbrush -tekniikan viiteopas

ZSoft Corporation

Näytä määrityksen linkki →