אישורי אבטחה: PEM, DER ו-PKCS#12
קידוד Base64 ASCII, אישורי DER בינאריים ומכלי מפתחות פרטיים.
הקבצים מעובדים מקומית בדפדפן באמצעות WebAssembly וממשקי HTML5. הם לעולם אינם עוזבים את המכשיר שלך, כך שאין העלאות לשרת או אחסון קבצים אצל צד שלישי.
התחל להמיר מיד במכשיר שלך - ללא המתנה להעלאה, ללא תור הורדה וללא הגבלת מהירות מצד שרת מרוחק.
השתמש בכלי זמין ללא צורך ביצירת חשבון, תשלום עבור תוכנית או הגעה למגבלת גודל קובץ מלאכותית. המר כמה שתרצה, כל עוד הדפדפן והמכשיר שלך מסוגלים לכך.
השוואת פורמטים ומפרטים טכניים
| פורמט פלט | סוג MIME | מפרט | סוג |
|---|---|---|---|
| PEM תעודת | application/x-pem-file | RFC-7468-PEM | תעודה מאובטחת בקידוד Base64 |
| CRT תעודת | application/x-x509-ca-cert | RFC-5280-X509 | תעודה ציבורית מסוג X.509 |
| CER תעודת | application/pkix-cert | RFC-5280-X509 | תעודת אבטחה מסוג X.509 |
| DER נתוני DER בינאריים | application/x-x509-ca-cert | RFC-5280-X509 | תעודה בינארית מסוג ASN.1 |
| P12 חבילת PKCS #12 | application/x-pkcs12 | RFC-7292-PKCS12 | ארכיון תעודות מוצפן |
| PFX חבילת | application/x-pkcs12 | RFC-7292-PKCS12 | חבילת החלפה אישית של Microsoft |
מפרטים טכניים וסקירת מקודדים
PEM לעומת DER: טקסט מול בינארי
DER הוא קידוד ASN.1 בינארי של אישור SSL/TLS. PEM הוא פשוט אותו נתון בינארי המומר לטקסט Base64 עם כותרות '-----BEGIN CERTIFICATE-----', המאפשר העתקה והדבקה של אישורים לתוך שרתי אינטרנט וקובצי תצורה.
PKCS#12 (.pfx / .p12): אריזת מפתח ואישור יחד
אישור PEM מכיל אך ורק את האישור הציבורי. בעת העברת אישורים בין שרתי Windows או מאגרי מפתחות של Java, חבילת PKCS#12 אורזת את האישור הציבורי, את שרשרת האמון המלאה של האישור ואת המפתח הפרטי המוצפן לקובץ יחיד המוגן בסיסמה.
0 בייט הועלו לשרתים חיצוניים. כל העיבוד התבצע באופן מקומי בארגז החול של הדפדפן שלך.