דחיסת זרמים: GZIP, BZIP2 ו-ZSTD
אלגוריתמים לדחיסת זרמים של קובץ יחיד וקודקים להעברה ברשת.
הקבצים מעובדים מקומית בדפדפן באמצעות WebAssembly וממשקי HTML5. הם לעולם אינם עוזבים את המכשיר שלך, כך שאין העלאות לשרת או אחסון קבצים אצל צד שלישי.
התחל להמיר מיד במכשיר שלך - ללא המתנה להעלאה, ללא תור הורדה וללא הגבלת מהירות מצד שרת מרוחק.
השתמש בכלי זמין ללא צורך ביצירת חשבון, תשלום עבור תוכנית או הגעה למגבלת גודל קובץ מלאכותית. המר כמה שתרצה, כל עוד הדפדפן והמכשיר שלך מסוגלים לכך.
השוואת פורמטים ומפרטים טכניים
| פורמט פלט | סוג MIME | מפרט | סוג |
|---|---|---|---|
| GZ זרם GZIP | application/gzip | RFC-1952-GZIP | זרם דחיסה מסוג GNU Zip DEFLATE |
| BR זרם Brotli | application/x-brotli | RFC-7932-BROTLI | זרם דחיסת אינטרנט מסוג Brotli |
| ZST זרם Zstandard | application/zstd | RFC-8878-ZSTD | מסגרת דחיסה בזמן אמת מסוג Zstandard |
| DEFLATE גולמי | application/octet-stream | RFC-1951-DEFLATE | זרם DEFLATE גולמי |
| LZ4 זרם | application/x-lz4 | LZ4-FRAME-SPEC | מסגרת בתים מהירה במיוחד מסוג LZ4 |
| GZ ארכיון GZIP | application/gzip | RFC-1952-GZIP | ארכיון קובץ יחיד דחוס בשיטת DEFLATE |
| ZIP ארכיון | application/zip | ISO-IEC-29500 | ארכיון דחוס סטנדרטי |
מפרטים טכניים וסקירת מקודדים
קודקים של דחיסה מול ארכיוני ריבוי קבצים
אי-הבנה נפוצה היא ש-GZIP (.gz) דומה לקובץ ZIP. הקובץ GZIP דוחס רק קובץ בודד או זרם נתונים. כדי לדחוס תיקיה שלמה בלינוקס, כלים מאחדים תחילה את התיקיה לקובץ יחיד באמצעות TAR, ולאחר מכן דוחסים את הקובץ הזה באמצעות GZIP (.tar.gz).
Zstandard (ZSTD): דחיסה הניתנת להגדרה
Zstandard הוא פורמט דחיסה ללא אובדן עם איזון מתכוונן בין מהירות ליחס דחיסה. התפוקה תלויה בנתונים, ברמה, במימוש ובחומרה; יש למדוד את עומס העבודה לפני הערכת הביצועים.
0 בייט הועלו לשרתים חיצוניים. כל העיבוד התבצע באופן מקומי בארגז החול של הדפדפן שלך.