המרת Deflate ל-GZIP

המרת זרם DEFLATE גולמי לזרם GZIP עוטפת את המטען הדחוס בתוך מיכל סטנדרטי עם כותרות מטא-דאטה כך שמערכות הפעלה וכלי אינטרנט יוכלו לקרוא אותו כראוי.

בחר או גרור קבצים לכאן

פרטי - הקבצים לעולם אינם עוזבים את המכשיר שלך

או הדבק Ctrl+V

בזמן שאתם מחכים לקבצים, אפשר לשחק ב-Code Rain

הבטחת פרטיות ללא העברת נתונים ברשת: 0 בייט הועלו לשרתים חיצוניים. כל העיבוד התבצע באופן מקומי בארגז החול של הדפדפן שלך.

השוואת פורמטים ומפרטים טכניים

מפרטDEFLATEGZIP
סוג MIMEapplication/zlibapplication/gzip
סוגזרם DEFLATE גולמימכולת זרם DEFLATE
דחיסהLZ77 + קידוד HuffmanDEFLATE (RFC 1951)
מפרט תקניIETF RFC 1950 / RFC 1951IETF RFC 1952
כותרת ביתים קסומים (Magic Bytes)78 01 / 78 9C / 78 DA (zlib header bytes)1F 8B (gzip ID1/ID2)

סקירת פורמטים ושימושים

זרמי נתונים של DEFLATE גולמי מכילים בייטים דחוסים ללא כותרות קבצים או סיכומי ביקורת נלווים. דפדפני אינטרנט וכלי רשת נאבקים לעיתים קרובות לעבד זרמים עירומים אלו מכיוון שהם חסרים מטא-דאטה כמו שמות קבצים מקוריים, חותמות זמן של שינוי או מזהי מערכת הפעלה. עטיפת נתונים גולמיים אלו לתוך מיכל GZIP פותרת בעיות תאימות אלו. מפתחים נתקלים בזרמי DEFLATE גולמיים בתוך פרוטוקולי רשת כגון דחיסת HTTP, מקטעי תמונת PNG וארכיוני ZIP. כאשר יש לשמור זרמים אלו כקבצים עצמאיים עבור כלי שורת הפקודה או הורדות אינטרנט סטנדרטיות, מהנדסים ממירים אותם לפורמט GZIP. זה מבטיח שכלי פענוח יזהו מיד את סוג הקובץ ויחלצו את התוכן מבלי להעלות שגיאות.

מפרטים טכניים וסקירת מקודדים

DEFLATE גולמי (RFC 1951 או זרם גולמי) משתמש בשילוב של התאמת מילון נע של LZ77 וקידוד הפמן כדי לדחוס רצפי בייטים ללא כותרות מסגור כלשהן. מיכל ה-GZIP (application/gzip) לוקח את מטען ה-DEFLATE המדויק הזה ועוטף אותו בכותרת קפדנית בת 10 בייטים המכילה חתימת מספר קסם בת שני בייטים (0x1F, 0x8B), דגלי שיטת דחיסה, זמן שינוי ומזהה מערכת הפעלה. מבנה ה-GZIP מוסיף גם נספח בן 8 בייטים המכיל סיכום ביקורת מסוג CRC32 לאימות תקינות הנתונים ואת גודל הקובץ הלא דחוס מודולו 2 בחזקת 32. סוג MIME מסוג application/zlib מציין מעטפת zlib סביב DEFLATE לפי RFC 1950, ולא זרם DEFLATE גולמי.

תאימות למערכות הפעלה ודפדפנים

זרמי GZIP מתהדרים בתאימות אוניברסלית בין מערכות הפעלה מודרניות, כולל Linux, macOS ו-Windows. כלי שורת הפקודה כמו gzip, gunzip ו-7-Zip קוראים קבצי GZIP באופן מקומי. דפדפני אינטרנט מטפלים באופן אוטומטי בפענוח GZIP בעת קבלת תגובות HTTP משרתים, אם כי DEFLATE גולמי דורש לעיתים קרובות לוגיקת מנתח מותאמת אישית בתוך סביבות JavaScript או מודולים של WebAssembly. התמיכה משתנה גם לפי האפליקציה, המכשיר, מערכת ההפעלה והגרסה.

מידע שימושי

ודא תמיד שכלי הפענוח שלך קורא את הסיומת של GZIP כראוי, מכיוון שסיכומי ביקורת CRC32 נלווים פגומים יגרמו לכלי החילוץ להפסיק את הפעולה גם אם מטען ה-DEFLATE הבסיסי שלם.

שאלות נפוצות

כיצד ממירים זרם DEFLATE גולמי לזרם GZIP מבלי לאבד איכות?

שני הפורמטים משתמשים בדחיסה ללא אובדן נתונים המבוססת על אותו אלגוריתם DEFLATE בדיוק. המרה ביניהם פשוט מוסיפה כותרות מיכל וסיכומי ביקורת סביב הבייטים הדחוסים הקיימים, כלומר, במהלך תהליך העטיפה לא מתרחש כל אובדן נתונים.

מה ההבדל בין זרם DEFLATE גולמי לזרם GZIP?

DEFLATE גולמי מכיל רק את המטען הדחוס ללא כותרות או תחתיות מזהות כלשהן. זרם GZIP הוא מיכל קבצים מתוקנן המוסיף כותרת בת 10 בייטים וסיכום ביקורת בן 8 בייטים בסוף לנתוני ה-DEFLATE הגולמיים לצורך מעקב מטא-דאטה וזיהוי שגיאות.