ईमेल फ़ाइलें: EML, MSG और MBOX संरचनाएं
MIME संदेश सीमाएं (boundaries), ईमेल हेडर, और क्रॉस-क्लाइंट माइग्रेशन।
फ़ाइलें WebAssembly और HTML5 API का उपयोग करके आपके ब्राउज़र में स्थानीय रूप से प्रोसेस की जाती हैं। वे कभी भी आपके डिवाइस से बाहर नहीं जातीं, इसलिए उन्हें सर्वर पर अपलोड नहीं किया जाता और न ही किसी तीसरे पक्ष के पास संग्रहीत किया जाता है।
अपने ही डिवाइस पर तुरंत कनवर्ट करना शुरू करें - कोई अपलोड प्रतीक्षा नहीं, कोई डाउनलोड कतार नहीं, और किसी दूरस्थ सर्वर द्वारा कोई थ्रॉटलिंग नहीं।
बिना खाता बनाए, किसी प्लान के लिए भुगतान किए या फ़ाइल आकार की कृत्रिम सीमा का सामना किए, प्रत्येक उपलब्ध टूल का उपयोग करें। अपने ब्राउज़र और डिवाइस की क्षमता के अनुसार जितनी बार चाहें कनवर्ट करें।
फ़ॉर्मेट तुलना और तकनीकी विनिर्देश
| आउटपुट फ़ॉर्मेट | MIME टाइप | विशिष्टता | प्रकार |
|---|---|---|---|
| EML RFC 822 ईमेल | message/rfc822 | RFC-5322-EMAIL | मानक ईमेल संदेश फ़ाइल |
| MSG Outlook | application/vnd.ms-outlook | MS-OXMSG-SPEC | Microsoft Outlook आइटम |
| MBOX फ़ाइल | application/mbox | RFC-5322-EMAIL | मेलबॉक्स समेकन फ़ाइल |
| VCF vCard संपर्क | text/vcard | RFC-6350-VCARD | इलेक्ट्रॉनिक बिजनेस कार्ड |
| ICS iCalendar | text/calendar | RFC-5545-ICAL | कैलेंडर और शेड्यूलिंग इवेंट |
| PDF दस्तावेज़ | application/pdf | ISO-32000-2 | पोर्टेबल दस्तावेज़ प्रारूप (Portable Document Format) |
| HTML ईमेल | text/html | RFC-5322-EMAIL | हाइपरटेक्स्ट ईमेल बॉडी |
| TXT सादा पाठ प्रतिलेख | text/plain | RFC-4180-CSV | निकाले गए पाठ का आउटपुट |
| CSV तालिका | text/csv | RFC-4180-CSV | कॉमा-सेपरेटेड वैल्यूज़ |
तकनीकी विनिर्देश और कोडेक विवरण
EML बनाम MSG: ओपन स्टैंडर्ड बनाम आउटलुक
EML आम तौर पर Internet Message Format और MIME नियमों के अनुसार संदेश सहेजता है; ईमेल क्लाइंट अपने भंडारण प्रारूप भी इस्तेमाल कर सकते हैं। MSG, Microsoft Outlook का संदेश प्रारूप है। MSG को EML में बदलने से अन्य सॉफ़्टवेयर में संदेश खोलना आसान हो सकता है, लेकिन प्रदर्शन और मेटाडेटा समर्थन ऐप के अनुसार बदलते हैं।
अटैचमेंट निकालना और हेडर सुरक्षित रखना
ईमेल में संदेश हेडर, MIME भाग और अटैचमेंट हो सकते हैं। EML को PDF में निर्यात करने से पढ़ने योग्य प्रति बन सकती है, लेकिन रूपांतरण अपने आप पूरा मूल संदेश ढाँचा सुरक्षित नहीं रखता और प्रामाणिकता या कानूनी ऑडिट योग्यता सिद्ध नहीं करता। मूल संदेश रखें और अपने कार्यप्रवाह की रिकॉर्ड-संरक्षण आवश्यकताओं का पालन करें।
बाहरी सर्वर पर 0 बाइट अपलोड किए गए। सारी प्रोसेसिंग आपके ब्राउज़र सैन्डबॉक्स में स्थानीय रूप से हुई।