MBOX से EML कन्वर्टर
एक MBOX आर्काइव को अलग-अलग EML फ़ाइलों में बदलने से एक विशाल ईमेल डेटाबेस अलग-अलग मानक संदेश दस्तावेज़ों में विभाजित हो जाता है।
फ़ॉर्मेट तुलना और तकनीकी विनिर्देश
| विशिष्टता | MBOX | EML |
|---|---|---|
| MIME टाइप | application/ | message/ |
| प्रकार | ईमेल मेलबॉक्स संयोजन आर्काइव | मानक ईमेल संदेश फ़ाइल |
| संपीड़न | कोई नहीं (टेक्स्ट संयोजन) | कोई नहीं (MIME मल्टीपार्ट एन्कोडेड) |
| मानक विनिर्देश | IETF RFC 4155 | IETF RFC 5322 |
| मैजिक बाइट्स हेडर | 46 72 6F 6D 20 (From separator line) | From: / Received: / Return-Path: (RFC 822/5322 header lines) |
फ़ॉर्मेट अवलोकन और अनुप्रयोग
MBOX में कई संदेश एक संग्रह में रखे जा सकते हैं, जबकि EML संदेशों को अलग-अलग रखता है। यदि प्राप्तकर्ता को अलग संदेश फ़ाइलें चाहिए, तो MBOX को बाँटना उपयोगी हो सकता है।
तकनीकी विनिर्देश और कोडेक विवरण
एक MBOX फ़ाइल (application/mbox) एक सादे-पाठ वाला संयोजन कंटेनर है जो कई ईमेल संदेशों को क्रमिक रूप से एक साथ जोड़ता है। यह यह चिह्नित करने के लिए कि एक संदेश कहाँ समाप्त होता है और अगला कहाँ से शुरू होता है, कड़ाई से सीमा के रूप में From - लाइन हेडर का उपयोग करता है। फ़ाइल संपीड़न शून्य है, जिसका अर्थ है कि कच्चा पाठ लगातार प्रवाहित होता है। इसके विपरीत, एक EML फ़ाइल अनुलग्नकों और HTML निकायों के लिए MIME मल्टीपार्ट एन्कोडिंग के साथ एक एकल ईमेल संदेश को पूरी तरह से संग्रहीत करने के लिए message/rfc822 MIME प्रकार का उपयोग करती है। रूपांतरण के दौरान, एक पार्सर MBOX स्ट्रीम को पढ़ता है, From - सीमाओं का पता लगाता है, प्रत्येक व्यक्तिगत टेक्स्ट ब्लॉक को निकालता है और इसे .eml एक्सटेंशन के साथ सहेजता है। यह प्रक्रिया लॉसलेस है क्योंकि दोनों प्रारूप RFC 5322 और RFC 822 में परिभाषित मानक इंटरनेट संदेश प्रारूप नियमों पर निर्भर करते हैं, जिसका अर्थ है कि कोई भी टेक्स्ट या बाइनरी अटैचमेंट डेटा बदला या संपीड़ित नहीं किया जाता है।
OS और ब्राउज़र संगतता
MBOX में आम तौर पर कई संदेश एक फ़ाइल में होते हैं, जबकि EML हर संदेश को अलग रखता है। Thunderbird और अन्य मेल क्लाइंट MBOX आयात कर सकते हैं, लेकिन समर्थन ऐप पर निर्भर करता है।
उपयोगी जानकारी
EML फ़ाइलों में विभाजित करने से पहले अपनी मूल MBOX फ़ाइलों की बैकअप प्रतियां रखें, क्योंकि दसियों हजार व्यक्तिगत संदेशों को संसाधित करने से गंतव्य निर्देशिकाएं अस्त-व्यस्त हो सकती हैं और पुरानी फ़ाइल प्रणालियां ओवरलोड हो सकती हैं।
अक्सर पूछे जाने वाले प्रश्न
आप गुणवत्ता खोए बिना MBOX आर्काइव को RFC 822 ईमेल में कैसे परिवर्तित करते हैं?
रूपांतरण संदेश और अटैचमेंट सुरक्षित रख सकता है, लेकिन परिणाम सॉफ़्टवेयर और MBOX विभाजकों को संभालने के तरीके पर निर्भर करता है। आउटपुट जाँचें।
MBOX आर्काइव और RFC 822 ईमेल में क्या अंतर है?
एक MBOX फ़ाइल एक एकल कंटेनर के रूप में कार्य करती है जिसमें पाठ मार्करों द्वारा अलग किए गए कई जुड़े हुए ईमेल होते हैं। एक EML फ़ाइल एक स्टैंडअलोन फ़ाइल है जिसमें RFC 822 और RFC 5322 मानकों का पालन करने वाला एक ईमेल संदेश होता है।