सुरक्षा प्रमाणपत्र: PEM, DER और PKCS#12
Base64 ASCII आर्मरिंग, बाइनरी DER प्रमाणपत्र, और प्राइवेट की कंटेनर।
फ़ाइलें WebAssembly और HTML5 API का उपयोग करके आपके ब्राउज़र में स्थानीय रूप से प्रोसेस की जाती हैं। वे कभी भी आपके डिवाइस से बाहर नहीं जातीं, इसलिए उन्हें सर्वर पर अपलोड नहीं किया जाता और न ही किसी तीसरे पक्ष के पास संग्रहीत किया जाता है।
अपने ही डिवाइस पर तुरंत कनवर्ट करना शुरू करें - कोई अपलोड प्रतीक्षा नहीं, कोई डाउनलोड कतार नहीं, और किसी दूरस्थ सर्वर द्वारा कोई थ्रॉटलिंग नहीं।
बिना खाता बनाए, किसी प्लान के लिए भुगतान किए या फ़ाइल आकार की कृत्रिम सीमा का सामना किए, प्रत्येक उपलब्ध टूल का उपयोग करें। अपने ब्राउज़र और डिवाइस की क्षमता के अनुसार जितनी बार चाहें कनवर्ट करें।
फ़ॉर्मेट तुलना और तकनीकी विनिर्देश
| आउटपुट फ़ॉर्मेट | MIME टाइप | विशिष्टता | प्रकार |
|---|---|---|---|
| PEM प्रमाणपत्र | application/x-pem-file | RFC-7468-PEM | Base64 आर्मर्ड प्रमाणपत्र |
| CRT प्रमाणपत्र | application/x-x509-ca-cert | RFC-5280-X509 | X.509 सार्वजनिक प्रमाणपत्र |
| CER प्रमाणपत्र | application/pkix-cert | RFC-5280-X509 | X.509 सुरक्षा प्रमाणपत्र |
| DER बाइनरी | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1 बाइनरी प्रमाणपत्र |
| P12 PKCS #12 बंडल | application/x-pkcs12 | RFC-7292-PKCS12 | एन्क्रिप्टेड प्रमाणपत्र संग्रह |
| PFX पैकेज | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft पर्सनल एक्सचेंज |
तकनीकी विनिर्देश और कोडेक विवरण
PEM बनाम DER: टेक्स्ट बनाम बाइनरी
DER एक SSL/TLS प्रमाणपत्र का बाइनरी ASN.1 एन्कोडिंग है। PEM सीधे वही बाइनरी डेटा है जिसे '-----BEGIN CERTIFICATE-----' हेडर के साथ Base64 टेक्स्ट में बदला गया है, जिससे प्रमाणपत्रों को वेब सर्वर और टेक्स्ट कॉन्फ़िगरेशन में आसानी से कॉपी-पेस्ट किया जा सकता है।
PKCS#12 (.pfx / .p12): की और प्रमाणपत्र को बंडल करना
एक PEM प्रमाणपत्र में केवल पब्लिक प्रमाणपत्र होता है। विंडोज सर्वर या जावा कीस्टोर के बीच प्रमाणपत्रों को माइग्रेट करते समय, PKCS#12 पब्लिक प्रमाणपत्र, संपूर्ण प्रमाणपत्र ट्रस्ट चेन, और एन्क्रिप्टेड प्राइवेट की को एक ही पासवर्ड-संरक्षित फ़ाइल में पैक करता है।
बाहरी सर्वर पर 0 बाइट अपलोड किए गए। सारी प्रोसेसिंग आपके ब्राउज़र सैन्डबॉक्स में स्थानीय रूप से हुई।