メールファイル:EML、MSG、MBOXの構造
MIME メッセージの境界、メールヘッダー、メールクライアント間の移行について解説します。
徹底したプライバシー保護
ファイルはWebAssemblyとHTML5 APIを使用し、お使いのブラウザ内でローカル処理されます。外部サーバーへのアップロードやサードパーティによるファイルの保存は一切行われないため、データがデバイスの外に出ることはありません。
待ち時間なし。速度制限なし。
お使いのデバイス上ですぐに変換を開始できます。アップロードの待ち時間やダウンロードのキュー、リモートサーバーによる速度制限はありません。
完全無料、無制限アクセス
アカウントの作成、有料プランへの加入、人為的なファイルサイズ制限を受けることなく、すべてのツールを自由にご利用いただけます。ブラウザとデバイスの性能の限界まで、何度でも変換可能です。
フォーマットの比較と技術仕様
| 出力形式 | MIMEタイプ | 仕様 | タイプ |
|---|---|---|---|
| EML RFC 822メール | message/rfc822 | RFC-5322-EMAIL | 標準メールメッセージファイル |
| MSG Outlook | application/vnd.ms-outlook | MS-OXMSG-SPEC | Microsoft Outlookアイテムファイル |
| MBOX アーカイブ | application/mbox | RFC-5322-EMAIL | メールボックス結合ファイル |
| VCF vCard連絡先 | text/vcard | RFC-6350-VCARD | 電子名刺ファイル |
| ICS iCalendar | text/calendar | RFC-5545-ICAL | カレンダーおよびスケジュールイベント |
| PDF 文書 | application/pdf | ISO-32000-2 | ポータブル・ドキュメント・フォーマット |
| HTML 文書 | text/html | RFC-5322-EMAIL | HTML形式の文書 |
| TXT プレーンテキスト | text/plain | RFC-4180-CSV | 書式なしテキスト |
| CSV テーブル | text/csv | RFC-4180-CSV | カンマ区切り値データ |
技術仕様とコーデックの詳細
EML対MSG:オープン標準とOutlook
EMLは通常、Internet Message FormatとMIMEの規約に沿ってメッセージを保存しますが、メールクライアントが独自の保存形式を使う場合もあります。MSGはMicrosoft Outlookのメッセージ形式です。MSGをEMLに変換すると他のソフトで開きやすくなることがありますが、表示やメタデータの対応はアプリによって異なります。
添付ファイルの抽出とヘッダーの保持
メールにはメッセージヘッダー、MIMEパート、添付ファイルが含まれることがあります。EMLをPDFに書き出すと読みやすいコピーを作れますが、変換だけで元のメッセージ構造全体が保存されたり、真正性や法的な監査可能性が証明されたりするわけではありません。元のメッセージを保管し、業務の記録要件に従ってください。
役立つ情報
外部サーバーへのデータ送信は0バイトです。すべての処理はお使いのブラウザのサンドボックス内でローカルに実行されます。