技術基準と信頼できる情報源

File2File.app全体で参照されている公式標準、RFC、およびフォーマット仕様。

最終更新日:2026年9月

標準化機関のレジストリ

File2File.appのすべての変換ルール、MIMEタイプ、マジックバイトの定義は、国際機関が公開する公式規格に基づいています:

ISO 32000-2:2020 文書管理 - ポータブル・ドキュメント・フォーマット - パート 2: PDF 2.0

国際標準化機構

仕様リンクを表示 →

ISO/IEC 29500-1:2016 情報技術 - 文書記述および処理言語 - オフィス・オープン XML ファイル・フォーマット

ISO/IEC JTC 1/SC 34

仕様リンクを表示 →

ポータブル・ネットワーク・グラフィックス (PNG) 仕様書 (第3版)

World Wide Web Consortium (W3C)

仕様リンクを表示 →

スケーラブル・ベクター・グラフィックス (SVG) 2 仕様書

World Wide Web Consortium (W3C)

仕様リンクを表示 →

ITU-T 勧告 T.81 / ISO/IEC 10918-1: 情報技術 - 連続階調静止画像のデジタル圧縮および符号化

国際電気通信連合

仕様リンクを表示 →

RFC 6386: VP8 データ・フォーマットおよび復号ガイド (WebP コア)

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

ISO/IEC 23008-12:2024 高効率画像ファイル・フォーマット (HEIF)

国際標準化機構

仕様リンクを表示 →

AV1 画像ファイル・フォーマット (AVIF) 仕様書 v1.1.0

Alliance for Open Media

仕様リンクを表示 →

RFC 5334: Ogg メディア・タイプおよびコンテナ仕様書

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 6716: Opus オーディオ・コーデックの定義

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

ISO/IEC 14496-14:2020 情報技術 - オーディオ・ビジュアル・オブジェクトの符号化 - パート 14: MP4 ファイル・フォーマット

国際標準化機構

仕様リンクを表示 →

EPUB 3.3 仕様書

World Wide Web Consortium (W3C)

仕様リンクを表示 →

WOFF ファイル・フォーマット 2.0 仕様書

World Wide Web Consortium (W3C)

仕様リンクを表示 →

AutoCAD 図面交換フォーマット (DXF) リファレンス

Autodesk Developer Network

仕様リンクを表示 →

RFC 4180: カンマ区切り値 (CSV) ファイルの共通フォーマットおよび MIME タイプ

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

POSIX.1-2017 / IEEE Std 1003.1: 情報技術標準 - 拡張 TAR アーカイブ・フォーマット

IEEE & The Open Group

仕様リンクを表示 →

RFC 1952: GZIP ファイル・フォーマット仕様書 バージョン 4.3

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

7z アーカイブ・フォーマット仕様書および LZMA SDK

7-Zip / Igor Pavlov

仕様リンクを表示 →

bzip2 および libbzip2 高品質データ・コンプレッサー仕様書

Julian Seward / Sourceware

仕様リンクを表示 →

RAR 5.0 アーカイブ・ファイル・フォーマット技術仕様書

Eugene Roshal / Win.rar GmbH

仕様リンクを表示 →

ISO 9660:1988 情報処理 - 情報交換用 CD-ROM のボリュームおよびファイル構造

国際標準化機構

仕様リンクを表示 →

仮想マシン・ディスク (VMDK) フォーマット仕様書 バージョン 5.0

VMware / Broadcom

仕様リンクを表示 →

仮想ハード・ディスク (VHD) イメージ・フォーマット仕様書

Microsoft Corporation

仕様リンクを表示 →

Apple ディスク・イメージ (DMG) ユニバーサル・ディスク・イメージ・フォーマット仕様書

Apple Inc.

仕様リンクを表示 →

Mobipocket ファイル・フォーマット仕様書およびオープン・パッケージング・ストラクチャー

Mobipocket / Amazon

仕様リンクを表示 →

Amazon Kindle フォーマット 8 (AZW3) 出版ガイドライン

Amazon Kindle Direct Publishing

仕様リンクを表示 →

FictionBook 2.0 (FB2) XML 電子書籍仕様書

FictionBook Open Source Project

仕様リンクを表示 →

WebVTT: ウェブ・ビデオ・テキスト・トラック・フォーマット

World Wide Web Consortium (W3C)

仕様リンクを表示 →

Matroska / SubRip 字幕仕様書 (SRT)

Matroska Specification Project

仕様リンクを表示 →

アドバンスト・サブステーション・アルファ v4.00+ スクリプト・フォーマット仕様書

Doom9 / Aegisub Community

仕様リンクを表示 →

Khronos glTF 2.0 仕様書 (GL トランスミッション・フォーマット)

Khronos Group 3D Formats Working Group

仕様リンクを表示 →

ポリゴン・ファイル・フォーマット (PLY) 仕様書

Stanford University Computer Graphics Laboratory

仕様リンクを表示 →

Autodesk FBX SDK およびバイナリ・アセット仕様書

Autodesk Developer Network

仕様リンクを表示 →

SQLite データベース・ファイル・フォーマット

SQLite Development Team

仕様リンクを表示 →

ISO/IEC 9075: 情報技術 - データベース言語 - SQL

国際標準化機構

仕様リンクを表示 →

TIFF リビジョン 6.0 仕様書

Adobe Systems Incorporated

仕様リンクを表示 →

Microsoft Windows ビットマップ (BMP) ファイル・フォーマット仕様書

Microsoft Developer Network

仕様リンクを表示 →

Truevision TGA ファイル・フォーマット仕様書 バージョン 2.0

Truevision / AT&T

仕様リンクを表示 →

Microsoft DirectDraw サーフェス (DDS) プログラミング・ガイドおよびフォーマット仕様書

Microsoft DirectX Graphics Documentation

仕様リンクを表示 →

Adobe デジタル・ネガティブ (DNG) 仕様書 バージョン 1.6.0.0

Adobe Systems Incorporated

仕様リンクを表示 →

キヤノン デジタルカメラ RAW ファイル・フォーマット仕様書 (CR2)

Canon Inc. / ExifTool Metadata Project

仕様リンクを表示 →

ニコン電子フォーマット (NEF) 技術リファレンス

Nikon Corporation / LibRaw Project

仕様リンクを表示 →

ソニー・アルファ RAW (ARW) 仕様書およびメタデータ・リファレンス

Sony Corporation / ExifTool Project

仕様リンクを表示 →

RFC 4648: Base16、Base32、および Base64 データ符号化方式

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

16進オブジェクト・ファイル・フォーマット仕様書 (Intel HEX)

Intel Corporation

仕様リンクを表示 →

RFC 7946: GeoJSON フォーマット

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

OGC KML 2.3 標準仕様書

Open Geospatial Consortium (OGC)

仕様リンクを表示 →

GPX: GPS 交換フォーマット 1.1 スキーマ

Topografix

仕様リンクを表示 →

ESRI シェープファイル技術説明ホワイトペーパー

Environmental Systems Research Institute (ESRI)

仕様リンクを表示 →

Adobe スウォッチ・エクスチェンジ (ASE) ファイル・フォーマット仕様書

Adobe Systems Developer Support

仕様リンクを表示 →

GIMP パレット (GPL) フォーマット文書

GNU Image Manipulation Program (GIMP) Project

仕様リンクを表示 →

CSS カラー・モジュール レベル 4 仕様書

World Wide Web Consortium (W3C)

仕様リンクを表示 →

YAML Ain't Markup Language (YAML) バージョン 1.2 仕様書

YAML.org Working Group

仕様リンクを表示 →

TOML: Tom's Obvious Minimal Language 仕様書 v1.0.0

TOML Open Source Project

仕様リンクを表示 →

拡張マークアップ言語 (XML) 1.0 (第5版)

World Wide Web Consortium (W3C)

仕様リンクを表示 →

フレキシブル画像転送システム (FITS) 標準 4.0 の定義

International Astronomical Union (IAU) FITS Working Group

仕様リンクを表示 →

HDF5 ファイル・フォーマット仕様書 バージョン 3.0

The HDF Group

仕様リンクを表示 →

NetCDF ファイル構造およびフォーマット仕様書

UCAR Unidata Program Center

仕様リンクを表示 →

NCBI FASTA 配列表現および Blast データベース・フォーマット

National Center for Biotechnology Information (NCBI)

仕様リンクを表示 →

タンパク質データバンク・コンテンツ・ガイド: 原子座標エントリ・フォーマット記述 v3.30

Worldwide Protein Data Bank (wwPDB)

仕様リンクを表示 →

RFC 7932: Brotli 圧縮データ・フォーマット

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 8878: Zstandard 圧縮および 'application/zstd' タイプ

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 1951: DEFLATE 圧縮データ・フォーマット仕様書 バージョン 1.3

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

LZ4 フレーム・フォーマット記述

Yann Collet / LZ4 Project

仕様リンクを表示 →

RFC 7468: PKIX、PKCS、および CMS 構造のテキスト符号化方式 (PEM)

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 5280: インターネット X.509 公開鍵インフラストラクチャ証明書プロファイル

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 7292: PKCS #12: 個人情報交換構文 v1.1

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 5322: インターネット・メッセージ・フォーマット

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 6350: vCard フォーマット仕様書 (vCard v4.0)

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

RFC 5545: インターネット・カレンダーおよびスケジューリング・コア・オブジェクト仕様書 (iCalendar)

Internet Engineering Task Force (IETF)

仕様リンクを表示 →

MS-OXMSG: Outlook アイテム (.msg) ファイル・フォーマット

Microsoft Corporation

仕様リンクを表示 →

QEMU コピー・オン・ライト・イメージ・フォーマット (QCOW2) 仕様書

QEMU Open Source Project

仕様リンクを表示 →

Microsoft SQL Server バックアップおよび復元技術アーキテクチャ

Microsoft Corporation

仕様リンクを表示 →

hOCR 1.2 フォーマット仕様書 (OCR 表現標準)

hOCR Specification Working Group

仕様リンクを表示 →

Tesseract オープンソース OCR エンジン・アーキテクチャおよびページ・レイアウト解析

Tesseract OCR Open Source Project / Google

仕様リンクを表示 →

APNG (アニメーション・ポータブル・ネットワーク・グラフィックス) 仕様書

Mozilla Developer Network (MDN) / W3C

仕様リンクを表示 →

Lottie アニメーション・フォーマット仕様書

LottieFiles / Airbnb

仕様リンクを表示 →

ISO/IEC 14496-3: 情報技術 - オーディオ・ビジュアル・オブジェクトの符号化 - パート 3: オーディオ (AAC)

ISO/IEC JTC 1/SC 29

仕様リンクを表示 →

フリー・ロスレス・オーディオ・コーデック (FLAC) フォーマット仕様書

Xiph.Org Foundation

仕様リンクを表示 →

Apple ロスレス・オーディオ・コーデック (ALAC) オープンソース仕様書

Apple Inc.

仕様リンクを表示 →

オーディオ・インターチェンジ・ファイル・フォーマット (AIFF) 仕様書 v1.3

Apple Computer, Inc.

仕様リンクを表示 →

ダイレクト・ストリーム・デジタル (DSD / DSF) オーディオ・フォーマット仕様書

Sony Corporation / Philips

仕様リンクを表示 →

Monkey's Audio (.ape) ロスレス・オーディオ・フォーマット仕様書

Monkey's Audio / Matthew T. Ashland

仕様リンクを表示 →

[MS-EMF]: Enhanced Metafile Format

Microsoft Corporation

仕様リンクを表示 →

[MS-WMF]: Windows Metafile Format

Microsoft Corporation

仕様リンクを表示 →

Adobe Photoshop File Formats Specification

Adobe Systems Inc.

仕様リンクを表示 →

Canon Camera Image File Format (CIFF) Specification (CRW)

Canon Inc. / ExifTool Project

仕様リンクを表示 →

Canon Digital Camera RAW File Format Specification (CR3 / CRX ISOBMFF)

Canon Inc. / ExifTool Metadata Project

仕様リンクを表示 →

Fujifilm RAW Format (RAF) Technical Specification

Fujifilm Corporation / ExifTool Project

仕様リンクを表示 →

Kodak Professional Digital Camera RAW Formats Reference (DCR / KDC / K25)

Eastman Kodak Company / ExifTool Project

仕様リンクを表示 →

Leica Camera RAW Format (RWL / DNG) Technical Reference

Leica Camera AG / ExifTool Project

仕様リンクを表示 →

LibRaw RAW Image Formats Description & Supported Cameras

LibRaw LLC

仕様リンクを表示 →

Olympus / OM Digital Solutions RAW Format (ORF) Technical Reference

OM Digital Solutions / ExifTool Project

仕様リンクを表示 →

Panasonic Lumix RAW (RW2) Technical Reference

Panasonic Corporation / ExifTool Project

仕様リンクを表示 →

Pentax Electronic File (PEF / PTX) Format Reference

Ricoh Imaging Company / ExifTool Project

仕様リンクを表示 →

QuickTime File Format Specification

Apple Inc.

仕様リンクを表示 →

Samsung NX RAW Format (SRW) Technical Reference

Samsung Electronics / ExifTool Project

仕様リンクを表示 →

Sigma Foveon X3 Direct Image Sensor RAW Format (X3F)

Sigma Corporation / ExifTool Project

仕様リンクを表示 →

Truevision Targa ファイル形式仕様書 バージョン 2.0

Truevision Inc.

仕様リンクを表示 →

ZSoft Corporation Paintbrush 技術リファレンスマニュアル

ZSoft Corporation

仕様リンクを表示 →