セキュリティ証明書: PEM、DER、PKCS#12
Base64 による ASCII アーマリング、バイナリ DER 証明書、秘密鍵コンテナについて解説します。
徹底したプライバシー保護
ファイルはWebAssemblyとHTML5 APIを使用し、お使いのブラウザ内でローカル処理されます。外部サーバーへのアップロードやサードパーティによるファイルの保存は一切行われないため、データがデバイスの外に出ることはありません。
待ち時間なし。速度制限なし。
お使いのデバイス上ですぐに変換を開始できます。アップロードの待ち時間やダウンロードのキュー、リモートサーバーによる速度制限はありません。
完全無料、無制限アクセス
アカウントの作成、有料プランへの加入、人為的なファイルサイズ制限を受けることなく、すべてのツールを自由にご利用いただけます。ブラウザとデバイスの性能の限界まで、何度でも変換可能です。
フォーマットの比較と技術仕様
| 出力形式 | MIMEタイプ | 仕様 | タイプ |
|---|---|---|---|
| PEM 証明書 | application/x-pem-file | RFC-7468-PEM | Base64エンコード済み証明書 |
| CRT 証明書 | application/x-x509-ca-cert | RFC-5280-X509 | X.509公開証明書 |
| CER 証明書 | application/pkix-cert | RFC-5280-X509 | X.509セキュリティ証明書 |
| DER バイナリ | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1バイナリ証明書 |
| P12 PKCS #12バンドル | application/x-pkcs12 | RFC-7292-PKCS12 | 暗号化された証明書アーカイブ |
| PFX パッケージ | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft個人情報交換ファイル |
技術仕様とコーデックの詳細
PEM対DER: テキスト対バイナリ
DERはSSL/TLS証明書のバイナリASN.1エンコーディングです。PEMは、その正確なバイナリデータを「-----BEGIN CERTIFICATE-----」ヘッダー付きのBase64テキストに変換したものであり、証明書をWebサーバーやテキスト設定にコピーアンドペーストできるようにします。
PKCS#12 (.pfx / .p12): 鍵と証明書のバンドル
PEM 証明書には公開証明書しか含まれません。Windows サーバー間や Java キーストア間で証明書を移行するとき、PKCS#12 は公開証明書、証明書の完全な信頼チェーン、暗号化された秘密鍵を、パスワードで保護された 1 つのファイルにまとめます。
役立つ情報
外部サーバーへのデータ送信は0バイトです。すべての処理はお使いのブラウザのサンドボックス内でローカルに実行されます。