스트림 압축: GZIP, BZIP2 및 ZSTD
단일 파일 스트림 압축 알고리즘 및 웹 전송 코덱.
개인정보 보호를 우선한 설계
파일은 WebAssembly 및 HTML5 API를 사용해 브라우저에서 로컬로 처리됩니다. 파일은 기기 밖으로 전송되지 않으므로 서버 업로드나 제3자 파일 저장소를 이용하지 않습니다.
대기열 없음. 속도 제한 없음.
내 기기에서 바로 변환을 시작할 수 있습니다. 업로드 대기나 다운로드 대기열이 없으며, 원격 서버로 인한 속도 제한도 없습니다.
무료로 무제한 이용
계정을 만들거나 요금제를 결제하지 않고도 모든 도구를 이용할 수 있으며, 인위적인 파일 크기 제한도 없습니다. 브라우저와 기기가 처리할 수 있는 만큼 자주 변환할 수 있습니다.
형식 비교 및 기술 사양
| 출력 형식 | MIME 유형 | 사양 | 유형 |
|---|---|---|---|
| GZ IP 스트림 | application/gzip | RFC-1952-GZIP | GNU Zip DEFLATE 스트림 파일 |
| BR otli 스트림 | application/x-brotli | RFC-7932-BROTLI | Brotli 웹 압축 스트림 파일 |
| ZST andard 스트림 | application/zstd | RFC-8878-ZSTD | 실시간 Zstandard 프레임 파일 |
| DEFLATE 로우 | application/octet-stream | RFC-1951-DEFLATE | 로우 DEFLATE 스트림 |
| LZ4 스트림 | application/x-lz4 | LZ4-FRAME-SPEC | 초고속 LZ4 바이트 프레임 파일 |
| GZ IP 압축파일 | application/gzip | RFC-1952-GZIP | DEFLATE 압축 단일 파일 아카이브 |
| ZIP 압축파일 | application/zip | ISO-IEC-29500 | 표준 압축 아카이브 |
기술 사양 및 코덱 분석
압축 코덱 대 다중 파일 아카이브
흔한 오해 중 하나는 GZIP(.gz)이 ZIP 파일과 유사하다고 생각하는 것입니다. GZIP은 단일 파일 또는 스트림만 압축합니다. 리눅스에서 전체 폴더를 압축하기 위해 도구들은 먼저 TAR을 사용하여 폴더를 단일 파일로 결합한 다음, GZIP으로 해당 파일을 압축합니다(.tar.gz).
Zstandard (ZSTD): 조정 가능한 압축
Zstandard는 속도와 압축률의 균형을 조정할 수 있는 무손실 압축 형식입니다. 처리량은 데이터, 압축 수준, 구현, 하드웨어에 따라 달라지므로 성능을 추정하기 전에 실제 작업을 측정하세요.
유용한 정보
외부 서버로 업로드된 데이터는 0바이트입니다. 모든 처리는 브라우저 샌드박스 내에서 로컬로 수행되었습니다.