Standardy techniczne i źródła autorytatywne

Oficjalne standardy, dokumenty RFC i specyfikacje formatów przywoływane w całym File2File.app.

Ostatnia aktualizacja: wrzesień 2026

Rejestr organów normalizacyjnych

Każda zasada konwersji, typ MIME i definicja magicznego bajtu w File2File.app jest poparta oficjalnymi standardami publikowanymi przez organizacje międzynarodowe:

ISO 32000-2:2020 Zarządzanie dokumentami: Przenośny format dokumentu: Część 2: PDF 2.0

International Organization for Standardization

Zobacz link do specyfikacji →

ISO/IEC 29500-1:2016 Technologia informacyjna: Języki opisu i przetwarzania dokumentów: Format plików Office Open XML

ISO/IEC JTC 1/SC 34

Zobacz link do specyfikacji →

Specyfikacja formatu Portable Network Graphics (PNG) (wydanie trzecie)

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Specyfikacja Scalable Vector Graphics (SVG) 2

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Zalecenie ITU-T T.81 / ISO/IEC 10918-1: Technologia informacyjna: Cyfrowa kompresja i kodowanie obrazów nieruchomych o ciągłej tonacji

International Telecommunication Union

Zobacz link do specyfikacji →

RFC 6386: Format danych VP8 i przewodnik po dekodowaniu (rdzeń WebP)

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

ISO/IEC 23008-12:2024 Format plików obrazów o wysokiej efektywności (HEIF)

International Organization for Standardization

Zobacz link do specyfikacji →

Specyfikacja formatu plików obrazów AV1 (AVIF) w wersji 1.1.0

Alliance for Open Media

Zobacz link do specyfikacji →

RFC 5334: Typy multimediów Ogg i specyfikacja kontenera

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 6716: Definicja kodeka audio Opus

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

ISO/IEC 14496-14:2020 Technologia informacyjna: Kodowanie obiektów audiowizualnych: Część 14: Format pliku MP4

International Organization for Standardization

Zobacz link do specyfikacji →

Specyfikacja EPUB 3.3

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Specyfikacja formatu pliku WOFF 2.0

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Dokumentacja formatu wymiany rysunków AutoCAD (DXF)

Autodesk Developer Network

Zobacz link do specyfikacji →

RFC 4180: Wspólny format i typ MIME dla plików wartości rozdzielanych przecinkami (CSV)

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

POSIX.1-2017 / IEEE Std 1003.1: Standard technologii informacyjnej: Rozszerzony format archiwum TAR

IEEE & The Open Group

Zobacz link do specyfikacji →

RFC 1952: Specyfikacja formatu pliku GZIP w wersji 4.3

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

Specyfikacja formatu archiwum 7z i LZMA SDK

7-Zip / Igor Pavlov

Zobacz link do specyfikacji →

Specyfikacja wysokiej jakości kompresora danych bzip2 i libbzip2

Julian Seward / Sourceware

Zobacz link do specyfikacji →

Specyfikacja techniczna formatu pliku archiwum RAR 5.0

Eugene Roshal / Win.rar GmbH

Zobacz link do specyfikacji →

ISO 9660:1988 Przetwarzanie informacji: Struktura wolumenu i plików na dysku CD-ROM do wymiany informacji

International Organization for Standardization

Zobacz link do specyfikacji →

Specyfikacja formatu dysku maszyny wirtualnej (VMDK) w wersji 5.0

VMware / Broadcom

Zobacz link do specyfikacji →

Specyfikacja formatu obrazu wirtualnego dysku twardego (VHD)

Microsoft Corporation

Zobacz link do specyfikacji →

Specyfikacja uniwersalnego formatu obrazu dysku Apple (DMG)

Apple Inc.

Zobacz link do specyfikacji →

Specyfikacja formatu pliku Mobipocket i struktura otwartego pakowania

Mobipocket / Amazon

Zobacz link do specyfikacji →

Wytyczne publikowania w formacie Amazon Kindle Format 8 (AZW3)

Amazon Kindle Direct Publishing

Zobacz link do specyfikacji →

Specyfikacja e-booka XML FictionBook 2.0 (FB2)

FictionBook Open Source Project

Zobacz link do specyfikacji →

WebVTT: Format ścieżek tekstowych wideo sieci Web

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Specyfikacja napisów Matroska / SubRip (SRT)

Matroska Specification Project

Zobacz link do specyfikacji →

Specyfikacja formatu skryptu Advanced SubStation Alpha w wersji 4.00+

Doom9 / Aegisub Community

Zobacz link do specyfikacji →

Specyfikacja Khronos glTF 2.0 (GL Transmission Format)

Khronos Group 3D Formats Working Group

Zobacz link do specyfikacji →

Specyfikacja formatu pliku wielokątów (PLY)

Stanford University Computer Graphics Laboratory

Zobacz link do specyfikacji →

Autodesk FBX SDK i specyfikacja zasobów binarnych

Autodesk Developer Network

Zobacz link do specyfikacji →

Format pliku bazy danych SQLite

SQLite Development Team

Zobacz link do specyfikacji →

ISO/IEC 9075: Technologia informacyjna: Języki baz danych: SQL

International Organization for Standardization

Zobacz link do specyfikacji →

Specyfikacja TIFF w wersji 6.0

Adobe Systems Incorporated

Zobacz link do specyfikacji →

Specyfikacja formatu pliku bitmapy Microsoft Windows (BMP)

Microsoft Developer Network

Zobacz link do specyfikacji →

Specyfikacja formatu pliku Truevision TGA w wersji 2.0

Truevision / AT&T

Zobacz link do specyfikacji →

Przewodnik programowania i specyfikacja formatu Microsoft DirectDraw Surface (DDS)

Microsoft DirectX Graphics Documentation

Zobacz link do specyfikacji →

Specyfikacja Adobe Digital Negative (DNG) w wersji 1.6.0.0

Adobe Systems Incorporated

Zobacz link do specyfikacji →

Specyfikacja formatu pliku RAW aparatu cyfrowego Canon (CR2)

Canon Inc. / ExifTool Metadata Project

Zobacz link do specyfikacji →

Dokumentacja techniczna Nikon Electronic Format (NEF)

Nikon Corporation / LibRaw Project

Zobacz link do specyfikacji →

Specyfikacja Sony Alpha RAW (ARW) i dokumentacja metadanych

Sony Corporation / ExifTool Project

Zobacz link do specyfikacji →

RFC 4648: Kodowania danych Base16, Base32 i Base64

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

Specyfikacja formatu pliku obiektowego w kodzie szesnastkowym (Intel HEX)

Intel Corporation

Zobacz link do specyfikacji →

RFC 7946: Format GeoJSON

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

Standardowa specyfikacja OGC KML 2.3

Open Geospatial Consortium (OGC)

Zobacz link do specyfikacji →

Schemat GPX: GPS Exchange Format 1.1

Topografix

Zobacz link do specyfikacji →

Biała księga opisu technicznego ESRI Shapefile

Environmental Systems Research Institute (ESRI)

Zobacz link do specyfikacji →

Specyfikacja formatu pliku Adobe Swatch Exchange (ASE)

Adobe Systems Developer Support

Zobacz link do specyfikacji →

Dokumentacja formatu palety GIMP (GPL)

GNU Image Manipulation Program (GIMP) Project

Zobacz link do specyfikacji →

Specyfikacja modułu kolorów CSS w wersji 4

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Specyfikacja YAML Ain't Markup Language (YAML) w wersji 1.2

YAML.org Working Group

Zobacz link do specyfikacji →

TOML: Specyfikacja oczywistego i minimalnego języka Toma w wersji 1.0.0

TOML Open Source Project

Zobacz link do specyfikacji →

Język znaczników rozszerzalnych (XML) 1.0 (piąte wydanie)

World Wide Web Consortium (W3C)

Zobacz link do specyfikacji →

Definicja standardu elastycznego systemu transportu obrazów (FITS) 4.0

International Astronomical Union (IAU) FITS Working Group

Zobacz link do specyfikacji →

Specyfikacja formatu pliku HDF5 w wersji 3.0

The HDF Group

Zobacz link do specyfikacji →

Specyfikacja struktury i formatu pliku NetCDF

UCAR Unidata Program Center

Zobacz link do specyfikacji →

Reprezentacja sekwencji NCBI FASTA i format bazy danych Blast

National Center for Biotechnology Information (NCBI)

Zobacz link do specyfikacji →

Przewodnik po zawartości Protein Data Bank: Opis formatu wpisu współrzędnych atomowych w wersji 3.30

Worldwide Protein Data Bank (wwPDB)

Zobacz link do specyfikacji →

RFC 7932: Format skompresowanych danych Brotli

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 8878: Kompresja Zstandard i typ 'application/zstd'

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 1951: Specyfikacja formatu skompresowanych danych DEFLATE w wersji 1.3

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

Opis formatu ramki LZ4

Yann Collet / LZ4 Project

Zobacz link do specyfikacji →

RFC 7468: Tekstowe kodowania struktur PKIX, PKCS i CMS (PEM)

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 5280: Profil certyfikatów infrastruktury klucza publicznego Internet X.509

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 7292: PKCS #12: Składnia wymiany informacji osobistych w wersji 1.1

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 5322: Format wiadomości internetowych

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 6350: Specyfikacja formatu vCard (vCard w wersji 4.0)

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

RFC 5545: Specyfikacja podstawowego obiektu kalendarza i planowania w internecie (iCalendar)

Internet Engineering Task Force (IETF)

Zobacz link do specyfikacji →

MS-OXMSG: Format pliku elementów programu Outlook (.msg)

Microsoft Corporation

Zobacz link do specyfikacji →

Specyfikacja formatu obrazu Copy-On-Write programu QEMU (QCOW2)

QEMU Open Source Project

Zobacz link do specyfikacji →

Architektura techniczna tworzenia kopii zapasowych i przywracania programu Microsoft SQL Server

Microsoft Corporation

Zobacz link do specyfikacji →

Specyfikacja formatu hOCR 1.2 (standard reprezentacji OCR)

hOCR Specification Working Group

Zobacz link do specyfikacji →

Architektura silnika OCR Tesseract o otwartym kodzie źródłowym i analiza układu strony

Tesseract OCR Open Source Project / Google

Zobacz link do specyfikacji →

Specyfikacja APNG (Animated Portable Network Graphics)

Mozilla Developer Network (MDN) / W3C

Zobacz link do specyfikacji →

Specyfikacja formatu animacji Lottie

LottieFiles / Airbnb

Zobacz link do specyfikacji →

ISO/IEC 14496-3: Technologia informacyjna: Kodowanie obiektów audiowizualnych: Część 3: Audio (AAC)

ISO/IEC JTC 1/SC 29

Zobacz link do specyfikacji →

Specyfikacja formatu bezstratnego kodeka audio (FLAC)

Xiph.Org Foundation

Zobacz link do specyfikacji →

Specyfikacja otwartoźródłowa bezstratnego kodeka audio Apple (ALAC)

Apple Inc.

Zobacz link do specyfikacji →

Specyfikacja formatu pliku wymiany audio (AIFF) w wersji 1.3

Apple Computer, Inc.

Zobacz link do specyfikacji →

Specyfikacja formatu audio Direct Stream Digital (DSD / DSF)

Sony Corporation / Philips

Zobacz link do specyfikacji →

Specyfikacja bezstratnego formatu audio Monkey's Audio (.ape)

Monkey's Audio / Matthew T. Ashland

Zobacz link do specyfikacji →

[MS-EMF]: Enhanced Metafile Format

Microsoft Corporation

Zobacz link do specyfikacji →

[MS-WMF]: Windows Metafile Format

Microsoft Corporation

Zobacz link do specyfikacji →

Adobe Photoshop File Formats Specification

Adobe Systems Inc.

Zobacz link do specyfikacji →

Canon Camera Image File Format (CIFF) Specification (CRW)

Canon Inc. / ExifTool Project

Zobacz link do specyfikacji →

Canon Digital Camera RAW File Format Specification (CR3 / CRX ISOBMFF)

Canon Inc. / ExifTool Metadata Project

Zobacz link do specyfikacji →

Fujifilm RAW Format (RAF) Technical Specification

Fujifilm Corporation / ExifTool Project

Zobacz link do specyfikacji →

Kodak Professional Digital Camera RAW Formats Reference (DCR / KDC / K25)

Eastman Kodak Company / ExifTool Project

Zobacz link do specyfikacji →

Leica Camera RAW Format (RWL / DNG) Technical Reference

Leica Camera AG / ExifTool Project

Zobacz link do specyfikacji →

LibRaw RAW Image Formats Description & Supported Cameras

LibRaw LLC

Zobacz link do specyfikacji →

Olympus / OM Digital Solutions RAW Format (ORF) Technical Reference

OM Digital Solutions / ExifTool Project

Zobacz link do specyfikacji →

Panasonic Lumix RAW (RW2) Technical Reference

Panasonic Corporation / ExifTool Project

Zobacz link do specyfikacji →

Pentax Electronic File (PEF / PTX) Format Reference

Ricoh Imaging Company / ExifTool Project

Zobacz link do specyfikacji →

Specyfikacja formatu pliku QuickTime

Apple Inc.

Zobacz link do specyfikacji →

Dokumentacja techniczna formatu Samsung NX RAW (SRW)

Samsung Electronics / ExifTool Project

Zobacz link do specyfikacji →

Format RAW bezpośredniego czujnika obrazu Sigma Foveon X3 (X3F)

Sigma Corporation / ExifTool Project

Zobacz link do specyfikacji →

Specyfikacja formatu pliku Truevision Targa, wersja 2.0

Truevision Inc.

Zobacz link do specyfikacji →

Podręcznik techniczny programu Paintbrush wydany przez ZSoft Corporation

ZSoft Corporation

Zobacz link do specyfikacji →