Сертификаты безопасности: PEM, DER и PKCS#12
ASCII-представление в Base64, бинарные сертификаты DER и контейнеры закрытых ключей.
Файлы обрабатываются локально в Вашем браузере с помощью WebAssembly и HTML5 API. Они никогда не покидают Ваше устройство, что исключает загрузку на серверы или хранение сторонними сервисами.
Начинайте конвертацию мгновенно на собственном устройстве - без ожидания загрузки, очередей на скачивание и замедления со стороны удаленного сервера.
Пользуйтесь всеми доступными инструментами без создания учетной записи, оплаты тарифа и искусственных ограничений на размер файлов. Конвертируйте файлы так часто, как позволяют Ваш браузер и устройство.
Сравнение форматов и технические характеристики
| Выходной формат | MIME-тип | Характеристика | Тип |
|---|---|---|---|
| PEM сертификат | application/x-pem-file | RFC-7468-PEM | Сертификат в кодировке Base64 |
| CRT сертификат | application/x-x509-ca-cert | RFC-5280-X509 | Публичный сертификат X.509 |
| CER сертификат | application/pkix-cert | RFC-5280-X509 | Сертификат безопасности X.509 |
| DER бинарный файл | application/x-x509-ca-cert | RFC-5280-X509 | Двоичный сертификат ASN.1 |
| P12 Пакет PKCS #12 | application/x-pkcs12 | RFC-7292-PKCS12 | Зашифрованный архив сертификатов |
| PFX пакет | application/x-pkcs12 | RFC-7292-PKCS12 | Пакет личных сертификатов Microsoft |
Технические спецификации и разбор кодеков
PEM против DER: текст против двоичных данных
DER: это двоичное кодирование сертификата SSL/TLS в ASN.1. PEM представляет собой те же двоичные данные, преобразованные в текст Base64 с заголовками «-----BEGIN CERTIFICATE-----», что позволяет копировать сертификаты в веб-серверы и текстовые конфигурации.
PKCS#12 (.pfx / .p12): Объединение ключа и сертификата
Сертификат PEM содержит только открытый сертификат. При миграции сертификатов между серверами Windows или хранилищами ключей Java, PKCS#12 объединяет открытый сертификат, полную цепочку доверия сертификатов и зашифрованный закрытый ключ в один файл, защищенный паролем.
0 байт загружено на внешние серверы. Вся обработка выполнялась локально в песочнице Вашего браузера.