Потоковое сжатие: GZIP, BZIP2 и ZSTD
Алгоритмы сжатия потоков для отдельных файлов и кодеки веб-передачи.
Файлы обрабатываются локально в Вашем браузере с помощью WebAssembly и HTML5 API. Они никогда не покидают Ваше устройство, что исключает загрузку на серверы или хранение сторонними сервисами.
Начинайте конвертацию мгновенно на собственном устройстве - без ожидания загрузки, очередей на скачивание и замедления со стороны удаленного сервера.
Пользуйтесь всеми доступными инструментами без создания учетной записи, оплаты тарифа и искусственных ограничений на размер файлов. Конвертируйте файлы так часто, как позволяют Ваш браузер и устройство.
Сравнение форматов и технические характеристики
| Выходной формат | MIME-тип | Характеристика | Тип |
|---|---|---|---|
| GZ IP-поток | application/gzip | RFC-1952-GZIP | Поток сжатия GNU Zip DEFLATE |
| BR otli-поток | application/x-brotli | RFC-7932-BROTLI | Поток веб-сжатия Brotli |
| ZST andard-поток | application/zstd | RFC-8878-ZSTD | Фрейм Zstandard реального времени |
| DEFLATE Необработанный | application/octet-stream | RFC-1951-DEFLATE | Необработанный поток DEFLATE |
| LZ4 поток | application/x-lz4 | LZ4-FRAME-SPEC | Сверхбыстрый байтовый фрейм LZ4 |
| GZ Архив GZIP | application/gzip | RFC-1952-GZIP | Однофайловый архив, сжатый алгоритмом DEFLATE |
| ZIP Резервная копия | application/zip | ISO-IEC-29500 | Стандартный ZIP-архив резервной копии |
Технические спецификации и разбор кодеков
Кодеки сжатия против многофайловых архивов
Распространенное заблуждение заключается в том, что GZIP (.gz) аналогичен файлу ZIP. GZIP сжимает только один файл или поток. Для сжатия целой папки в Linux утилиты сначала объединяют ее в один файл с помощью TAR, а затем сжимают этот файл с помощью GZIP (.tar.gz).
Zstandard (ZSTD): Настраиваемое сжатие
Zstandard : формат сжатия без потерь с настраиваемым балансом скорости и степени сжатия. Пропускная способность зависит от данных, уровня, реализации и оборудования; измерьте нагрузку перед оценкой производительности.
0 байт загружено на внешние серверы. Вся обработка выполнялась локально в песочнице Вашего браузера.