Bezbednosni sertifikati: PEM, DER i PKCS#12
Base64 ASCII enkodovanje, binarni DER sertifikati i kontejneri privatnih ključeva.
Datoteke se obrađuju lokalno u vašem pregledaču pomoću tehnologija WebAssembly i HTML5 API-ja. Ne napuštaju vaš uređaj, pa se ne otpremaju na server niti skladište kod trećih strana.
Započnite konverziju odmah na sopstvenom uređaju - bez čekanja na otpremanje, reda za preuzimanje i gušenja brzine od strane udaljenog servera.
Koristite svaki dostupan alat bez otvaranja naloga, plaćanja paketa ili dostizanja veštačkih ograničenja veličine datoteke. Konvertujte onoliko često koliko vaš pregledač i uređaj mogu da podnesu.
Poređenje formata i tehničke specifikacije
| Izlazni format | MIME tip | Specifikacija | Tip |
|---|---|---|---|
| PEM sertifikat | application/x-pem-file | RFC-7468-PEM | Base64 zaštićeni sertifikat |
| CRT sertifikat | application/x-x509-ca-cert | RFC-5280-X509 | X.509 javni sertifikat |
| CER sertifikat | application/pkix-cert | RFC-5280-X509 | X.509 bezbednosni sertifikat |
| DER binarni fajl | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1 binarni sertifikat |
| P12 PKCS #12 paket | application/x-pkcs12 | RFC-7292-PKCS12 | Enkriptovana arhiva sertifikata |
| PFX paket | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft lična razmena sertifikata |
Tehničke specifikacije i analiza kodeka
PEM u odnosu na DER: Tekst prema binarnom formatu
DER je binarno kodiranje SSL/TLS sertifikata prema ASN.1 standardu. PEM je jednostavno taj isti binarni podatak konvertovan u Base64 tekst sa zaglavljima '-----BEGIN CERTIFICATE-----', što omogućava da se sertifikati kopiraju i nalepe u veb servere i tekstualne konfiguracije.
PKCS#12 (.pfx / .p12): Grupisanje ključa i sertifikata
PEM sertifikat sadrži samo javni sertifikat. Prilikom migracije sertifikata između Windows servera ili Java kejstorova, PKCS#12 pakuje javni sertifikat, kompletan lanac poverenja sertifikata i šifrovani privatni ključ u jednu datoteku zaštićenu lozinkom.
0 bajtova poslato spoljnim serverima. Sva obrada je izvršena lokalno u bezbednom okruženju vašeg pregledača.