ใบรับรองความปลอดภัย: PEM, DER และ PKCS#12
การห่อหุ้มด้วย Base64 ASCII, ใบรับรอง DER แบบไบนารี และคอนเทนเนอร์คีย์ส่วนตัว
ไฟล์จะถูกประมวลผลในเครื่องผ่านเบราว์เซอร์ด้วย WebAssembly และ HTML5 APIs ไฟล์จะไม่ออกจากอุปกรณ์ จึงไม่มีการอัปโหลดขึ้นเซิร์ฟเวอร์หรือจัดเก็บไฟล์กับบุคคลที่สาม
เริ่มแปลงไฟล์บนอุปกรณ์ของคุณได้ทันที ไม่ต้องรออัปโหลด ไม่ต้องรอคิวดาวน์โหลด และไม่ถูกจำกัดความเร็วจากเซิร์ฟเวอร์ภายนอก
ใช้เครื่องมือทั้งหมดได้โดยไม่ต้องสร้างบัญชีหรือซื้อแพ็กเกจ และไม่มีการตั้งเพดานขนาดไฟล์โดยพลการ แปลงไฟล์ได้ตามที่เบราว์เซอร์และอุปกรณ์ของคุณรองรับ
การเปรียบเทียบรูปแบบและข้อกำหนดทางเทคนิค
| รูปแบบผลลัพธ์ | ประเภท MIME | ข้อกำหนด | ประเภท |
|---|---|---|---|
| PEM ใบรับรอง | application/x-pem-file | RFC-7468-PEM | ใบรับรองที่เข้ารหัสด้วย Base64 |
| CRT ใบรับรอง | application/x-x509-ca-cert | RFC-5280-X509 | ใบรับรองสาธารณะมาตรฐาน X.509 |
| CER ใบรับรอง | application/pkix-cert | RFC-5280-X509 | ใบรับรองความปลอดภัยมาตรฐาน X.509 |
| DER ไบนารี | application/x-x509-ca-cert | RFC-5280-X509 | ใบรับรองรูปแบบไบนารี ASN.1 |
| P12 ชุดข้อมูล PKCS #12 | application/x-pkcs12 | RFC-7292-PKCS12 | คลังเก็บใบรับรองที่เข้ารหัสลับ |
| PFX แพ็กเกจ | application/x-pkcs12 | RFC-7292-PKCS12 | ไฟล์แลกเปลี่ยนข้อมูลส่วนบุคคลของ Microsoft |
ข้อกำหนดทางเทคนิคและรายละเอียดตัวแปลงสัญญาณ
ความแตกต่างระหว่าง PEM และ DER: ข้อความกับไบนารี
DER คือการเข้ารหัสแบบไบนารี ASN.1 ของใบรับรอง SSL/TLS ส่วน PEM คือข้อมูลไบนารีนั้นที่ถูกแปลงเป็นข้อความ Base64 พร้อมส่วนหัว '-----BEGIN CERTIFICATE-----' ซึ่งช่วยให้สามารถคัดลอกและวางใบรับรองลงในเว็บเซิร์ฟเวอร์และไฟล์กำหนดค่าที่เป็นข้อความได้
PKCS#12 (.pfx / .p12): การรวมคีย์และใบรับรองเข้าด้วยกัน
ใบรับรอง PEM มีเฉพาะใบรับรองสาธารณะ เมื่อย้ายใบรับรองระหว่างเซิร์ฟเวอร์ Windows หรือที่เก็บกุญแจ Java, PKCS#12 จะรวมใบรับรองสาธารณะ สายโซ่ความเชื่อถือของใบรับรองทั้งหมด และกุญแจส่วนตัวที่เข้ารหัสไว้ในไฟล์เดียวที่ป้องกันด้วยรหัสผ่าน
อัปโหลด 0 ไบต์ไปยังเซิร์ฟเวอร์ภายนอก การประมวลผลทั้งหมดเกิดขึ้นภายในแซนด์บ็อกซ์ของเบราว์เซอร์ของคุณ