แปลงไฟล์ทุกรูปแบบได้ในเบราว์เซอร์ของคุณ
แปลงไฟล์ได้ทันทีในเบราว์เซอร์ - ไม่ต้องอัปโหลด ไม่มีคิว ไม่มีข้อจำกัด และไม่มีแพ็กเกจเสียเงิน
วางไฟล์เพื่อดูว่าคุณทำอะไรกับไฟล์ได้บ้าง
ระบบจะระบุไฟล์บนอุปกรณ์ของคุณจากไบต์แรก โดยไม่มีการอัปโหลด
เครื่องมือแปลงไฟล์
เครื่องมือแปลงไฟล์ 250 คู่ ใน 28 กลุ่มรูปแบบไฟล์ที่คัดสรรมา
เครื่องมือบีบอัดไฟล์
ปรับไฟล์ผ่านเบราว์เซอร์โดยประมวลผลบนอุปกรณ์ และไม่อัปโหลดขึ้นเซิร์ฟเวอร์
เครื่องมือ PDF ขั้นสูงในเบราว์เซอร์
หมุน, ใส่ลายน้ำ, เพิ่มเลขหน้า และแยกเอกสาร PDF หลายหน้าด้วยการประมวลผลฝั่งไคลเอนต์ที่เป็นส่วนตัว. เป็นส่วนตัว - ไฟล์จะไม่ออกจากอุปกรณ์ของคุณ.
สารานุกรมรูปแบบไฟล์และข้อมูลทางเทคนิค
ข้อมูลลายเซ็นส่วนหัวในระดับไบต์ ข้อมูลจำเพาะแบบไบนารี มาตรฐาน ISO/RFC และประวัติความเป็นมา
ไฟล์ PDF
.pdfISO 32000-1 (2008) / ISO 32000-2 (2020)
รูปภาพ PNG
.pngW3C Recommendation (1996) / ISO/IEC 15948:2004
รูปภาพ JPEG
.jpgISO/IEC 10918-1 / ITU-T T.81
รูปภาพ WebP
.webpRFC 6386 / RIFF Container Specification
รูปภาพ AVIF
.avifISO/IEC 23000-22 (MIAF) / AOMedia Specification
เวกเตอร์ SVG
.svgW3C Recommendation (SVG 1.1 / SVG 2)
เอกสาร Word
.docxECMA-376 / ISO/IEC 29500
ไฟล์เก็บถาวร ZIP
.zipPKWARE APPNOTE / ISO/IEC 21320-1
ภาพ GIF เคลื่อนไหว
.gifCompuServe GIF87a / GIF89a Specification
ข้อมูล JSON
.jsonRFC 8259 / ECMA-404 / ISO/IEC 21778
ตาราง CSV
.csvRFC 4180 / IETF
การตั้งค่า XML
.xmlW3C Recommendation (XML 1.0 Fifth Edition)
เสียง AAC
.aacISO/IEC 13818-7 / ISO/IEC 14496-3
ไฟล์เสียง AIFF
.aiffApple / Electronic Arts IFF 85 Standard
ไฟล์ Apple Lossless
.alacApple Open Source / ISO 14496-12
ไฟล์ Monkey's Audio
.apeMatthew T. Ashland Open Specification
เสียง FLAC
.flacXiph.Org Open Standard / IETF Draft
M4A Audio
.m4aISO/IEC 14496-14 (MPEG-4 Part 14)
หนังสือเสียง M4B
.m4bApple Inc. / ISO/IEC 14496-14
เสียง MIDI
.midMIDI Manufacturers Association (MMA) / AMEI
เสียง MP3
.mp3ISO/IEC 11172-3 / ISO/IEC 13818-3
OGG Vorbis
.oggXiph.Org Foundation / IETF RFC 3533 & RFC 5334
เสียงพูด Opus
.opusIETF RFC 6716
เสียง WAV
.wavMicrosoft & IBM Resource Interchange File Format (RIFF)
วิดีโอ 3GP
.3gp3GPP TS 26.244 / ISO 14496-12
วิดีโอ AVI
.aviMicrosoft RIFF Specification / OpenDML Extension
วิดีโอ Flash
.flvAdobe Systems Flash Video File Format Specification
วิดีโอ Matroska
.mkvMatroska Open Standard / IETF Working Group Draft
QuickTime MOV
.movApple Computer Inc. QuickTime Specification
วิดีโอ MP4
.mp4ISO/IEC 14496-14:2003
วิดีโอ WebM
.webmWebM Project / IETF Cellar Working Group
Sony ARW
.arwTIFF/EP (ISO 12234-2) extension
Canon CR2
.cr2TIFF/EP (ISO 12234-2) derivative
Canon CR3
.cr3ISO/IEC 14496-12 (ISO Base Media File Format)
Canon CRW
.crwCamera Image File Format (CIFF)
Kodak DCR
.dcrTIFF-based proprietary format
Kodak DCS
.dcsTIFF-based Kodak proprietary
Adobe DNG
.dngISO 12234-2 compatible / Adobe Open Specification
Kodak DRF
.drfTIFF-based Kodak proprietary
Kodak K25
.k25TIFF-based Kodak proprietary
Kodak KDC
.kdcTIFF-based Kodak proprietary
Nikon NEF
.nefTIFF/EP (ISO 12234-2) extension
Nikon NRW
.nrwTIFF/EP (ISO 12234-2) derivative
Olympus ORF
.orfTIFF-based proprietary format
Pentax PEF
.pefTIFF/EP (ISO 12234-2) derivative
Pentax PTX
.ptxTIFF-based proprietary format
Fujifilm RAF
.rafFujifilm proprietary container
อิมเมจดิสก์ Raw
.rawTIFF-based / Panasonic proprietary
Panasonic RW2
.rw2Panasonic proprietary format
Leica RWL
.rwlTIFF-based Leica raw format; camera support varies by model
Sony SR2
.sr2TIFF-based proprietary format
Sony SRF
.srfTIFF-based proprietary format
Samsung SRW
.srwTIFF-based proprietary format
Sigma X3F
.x3fFoveon proprietary specification
ภาพ APNG เคลื่อนไหว
.apngW3C Community Group Report (2021) / Mozilla Extension
บิตแมป Windows
.bmpMicrosoft Windows Device-Independent Bitmap (DIB) Architecture
เคอร์เซอร์ Windows
.curMicrosoft Windows Resource Specification
ไฟล์ภาพวาด DXF
.dxfAutodesk Open CAD Specification
Enhanced Metafile
.emf[MS-EMF]: Enhanced Metafile Format Specification
Encapsulated PostScript
.epsAdobe Encapsulated PostScript File Format Specification v3.0
ภาพ OpenEXR
.exrAcademy Software Foundation (ASWF) Open Standard
ภาพ Radiance HDR
.hdrRadiance Synthetic Imaging System Standard
ภาพถ่าย HEIC
.heicISO/IEC 23008-12 (HEIF standard)
ไอคอน Windows
.icoMicrosoft Windows Icon Resource Specification
JFIF Image
.jfifITU-T T.871 / ISO/IEC 10918-5
บิตแมปแบบพกพา
.pbmNetpbm Library Standard
ZSoft PCX
.pcxZSoft PC Paintbrush Technical Reference Manual
ภาพระดับสีเทาแบบพกพา
.pgmNetpbm Library Standard
พิกเซลแมปแบบพกพา
.ppmNetpbm Library Standard
เอกสารขนาดใหญ่ของ Photoshop
.psbAdobe Photoshop File Format Specification (Version 2)
Photoshop Document
.psdAdobe Photoshop File Format Specification (Version 1)
Truevision TGA
.tgaTruevision TGA File Format Specification v2.0
รูปภาพ TIFF
.tiffTIFF Revision 6.0 (Adobe Systems)
Windows Metafile
.wmf[MS-WMF]: Windows Metafile Format Specification
ไฟล์เก็บถาวร 7-Zip
.7z7-Zip Open Architecture Specification
สตรีม Brotli
.brIETF RFC 7932
ไฟล์เก็บถาวร BZIP2
.bz2Bzip2 Open Source Standard
DEFLATE ดิบ
.deflateIETF RFC 1951 / RFC 1950 (zlib)
ไฟล์เก็บถาวร GZIP
.gzIETF RFC 1952
ไฟล์เก็บถาวร RAR
.rarRAR5 Architecture Specification
ไฟล์เก็บถาวร TAR
.tarPOSIX.1-1988 (ustar) / POSIX.1-2001 (pax)
ไฟล์เก็บถาวร Tar Gzip
.tar.gzPOSIX.1 ustar (RFC 1952 gzip wrapped)
สตรีม Zstandard
.zstIETF RFC 8878
Kindle Format 8
.azw3Amazon Proprietary KF8 Specification
อีบุ๊ก EPUB
.epubW3C EPUB 3.3 Recommendation
FictionBook 2.0
.fb2FictionBook Open XML Specification
เอกสาร HTML
.htmlWHATWG HTML Living Standard / W3C Recommendation
การตั้งค่า INI
.iniDe facto industry configuration standard
เอกสาร Markdown
.mdCommonMark Specification / GitHub Flavored Markdown (GFM)
อีบุ๊ก Mobipocket
.mobiMobipocket / Amazon Legacy Specification
คลังข้อมูลโปรตีน PDB
.pdbPalm OS File System Architecture Specification
ไฟล์สำรองข้อมูล SQL
.sqlISO/IEC 9075:2023 / ANSI SQL Standard
การตั้งค่า TOML
.tomlTOML v1.0.0 Specification
ข้อความธรรมดา
.txtISO/IEC 10646 / Unicode Standard / IETF RFC 2046
การตั้งค่า YAML
.yamlYAML 1.2.2 Specification
Dotenv
.envThe Twelve-Factor App Specification / Dotenv Standard
glTF ไบนารี
.glbISO/IEC 12113:2022 / Khronos Open Standard
glTF JSON
.gltfISO/IEC 12113:2022 / Khronos Open Standard
โมเดล Wavefront OBJ
.objWavefront Advanced Visualizer Specification
โมเดล Polygon PLY
.plyStanford University Computer Graphics Laboratory Standard
โมเดล Stereolithography STL
.stl3D Systems Stereolithography Specification
ไฟล์พิกัดเคมี
.xyzDe facto computational chemistry standard
ฟอนต์ OpenType
.otfISO/IEC 14496-22 (Open Font Format) / OpenType 1.9
ฟอนต์ TrueType
.ttfISO/IEC 14496-22 / Apple TrueType Reference Manual
Web Open Font Format
.woffW3C Recommendation (2012)
ฟอนต์เว็บ WOFF2
.woff2W3C Recommendation (2018)
ซับไตเติล Advanced SubStation Alpha
.assAdvanced SubStation Alpha v4.00+ Specification
ซับไตเติล SRT
.srtDe facto global subtitle standard
ซับไตเติล MicroDVD
.subMicroDVD File Specification
ซับไตเติล WebVTT
.vttW3C WebVTT Recommendation
ใบรับรอง CER
.cerITU-T X.509 / IETF RFC 5280
ใบรับรอง CRT
.crtITU-T X.509 / IETF RFC 5280
ไบนารี DER
.derITU-T Recommendation X.690
ชุดข้อมูล PKCS #12
.p12IETF RFC 7292 / PKCS #12 v1.1
ใบรับรอง PEM
.pemIETF RFC 7468 / RFC 1421
อีเมล RFC 822
.emlIETF RFC 5322 / RFC 2045 (MIME)
คลังข้อมูล MBOX
.mboxIETF RFC 4155
Outlook MSG
.msg[MS-OXMSG]: Outlook Item (.msg) File Format
รายชื่อผู้ติดต่อ vCard
.vcfIETF RFC 6350 (vCard v4.0)
ลำดับ FASTA
.fastaWidely used bioinformatics sequence format
ข้อมูลดาราศาสตร์ FITS
.fitsIAU FITS Standard v4.0
ไฟล์ GenBank
.gbNCBI GenBank Release Specification
ชุดข้อมูล HDF5
.hdf5The HDF Group Open Standard Specification
กริดข้อมูล NetCDF
.ncOGC NetCDF Core Standard / NASA ESDS Standard
GeoJSON
.geojsonIETF RFC 7946
Google KML
.kmlOGC KML 2.3 Standard
แทร็ก GPS GPX
.gpxTopografix GPX 1.1 Specification
ข้อมูลสำรองฐานข้อมูล
.bakMicrosoft SQL Server Backup Specification / Generic Backup
อิมเมจดิสก์ Apple
.dmgApple Universal Disk Image Format (UDIF)
อิมเมจ ISO 9660
.isoISO 9660:1988 / ECMA-119 / UDF (Universal Disk Format)
อิมเมจ QEMU QCOW2
.qcow2QEMU QCOW2 Image Format Specification
ฮาร์ดดิสก์เสมือน
.vhdMicrosoft Virtual Hard Disk Image Format Specification
ทำไมต้องเลือก File2File.app?
ออกแบบโดยคำนึงถึงความเป็นส่วนตัว
ไฟล์จะถูกประมวลผลในเครื่องผ่านเบราว์เซอร์ด้วย WebAssembly และ HTML5 APIs ไฟล์จะไม่ออกจากอุปกรณ์ จึงไม่มีการอัปโหลดขึ้นเซิร์ฟเวอร์หรือจัดเก็บไฟล์กับบุคคลที่สาม
ไม่มีคิว ไม่จำกัดความเร็ว
เริ่มแปลงไฟล์บนอุปกรณ์ของคุณได้ทันที ไม่ต้องรออัปโหลด ไม่ต้องรอคิวดาวน์โหลด และไม่ถูกจำกัดความเร็วจากเซิร์ฟเวอร์ภายนอก
ใช้งานฟรี ไม่จำกัด
ใช้เครื่องมือทั้งหมดได้โดยไม่ต้องสร้างบัญชีหรือซื้อแพ็กเกจ และไม่มีการตั้งเพดานขนาดไฟล์โดยพลการ แปลงไฟล์ได้ตามที่เบราว์เซอร์และอุปกรณ์ของคุณรองรับ