มาตรฐานทางเทคนิคและแหล่งข้อมูลที่เชื่อถือได้

มาตรฐานอย่างเป็นทางการ RFC และข้อกำหนดรูปแบบที่อ้างอิงทั่วทั้ง File2File.app

อัปเดตล่าสุด: กันยายน 2569

ทะเบียนองค์กรมาตรฐาน

กฎการแปลง ประเภท MIME และคำจำกัดความของลายเซ็นไฟล์บน File2File.app อ้างอิงมาตรฐานอย่างเป็นทางการที่เผยแพร่โดยองค์กรระหว่างประเทศ:

ISO 32000-2:2020 การจัดการเอกสาร - รูปแบบเอกสารแบบพกพา - ส่วนที่ 2: PDF 2.0

International Organization for Standardization

ดูลิงก์ข้อกำหนด →

ISO/IEC 29500-1:2016 เทคโนโลยีสารสนเทศ - ภาษาคำอธิบายและการประมวลผลเอกสาร - รูปแบบไฟล์ Office Open XML

ISO/IEC JTC 1/SC 34

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Portable Network Graphics (PNG) (ฉบับพิมพ์ครั้งที่ 3)

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Scalable Vector Graphics (SVG) 2

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

คำแนะนำ ITU-T T.81 / ISO/IEC 10918-1: เทคโนโลยีสารสนเทศ - การบีบอัดและการเข้ารหัสภาพนิ่งโทนสีต่อเนื่องแบบดิจิทัล

International Telecommunication Union

ดูลิงก์ข้อกำหนด →

RFC 6386: รูปแบบข้อมูล VP8 และคู่มือการถอดรหัส (WebP Core)

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

ISO/IEC 23008-12:2024 รูปแบบไฟล์ภาพประสิทธิภาพสูง (HEIF)

International Organization for Standardization

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ภาพ AV1 (AVIF) v1.1.0

Alliance for Open Media

ดูลิงก์ข้อกำหนด →

RFC 5334: ประเภทสื่อและข้อกำหนดคอนเทนเนอร์ Ogg

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 6716: คำจำกัดความของตัวแปลงสัญญาณเสียง Opus

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

ISO/IEC 14496-14:2020 เทคโนโลยีสารสนเทศ - การเข้ารหัสวัตถุภาพและเสียง - ส่วนที่ 14: รูปแบบไฟล์ MP4

International Organization for Standardization

ดูลิงก์ข้อกำหนด →

ข้อกำหนด EPUB 3.3

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ WOFF 2.0

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

ข้อมูลอ้างอิงรูปแบบการแลกเปลี่ยนภาพวาด AutoCAD (DXF)

Autodesk Developer Network

ดูลิงก์ข้อกำหนด →

RFC 4180: รูปแบบทั่วไปและประเภท MIME สำหรับไฟล์ค่าที่คั่นด้วยจุลภาค (CSV)

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

POSIX.1-2017 / IEEE Std 1003.1: มาตรฐานสำหรับเทคโนโลยีสารสนเทศ - รูปแบบคลังข้อมูล TAR แบบขยาย

IEEE & The Open Group

ดูลิงก์ข้อกำหนด →

RFC 1952: ข้อกำหนดรูปแบบไฟล์ GZIP เวอร์ชัน 4.3

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบคลังข้อมูล 7z และ LZMA SDK

7-Zip / Igor Pavlov

ดูลิงก์ข้อกำหนด →

ข้อกำหนดเครื่องมือบีบอัดข้อมูลคุณภาพสูง bzip2 และ libbzip2

Julian Seward / Sourceware

ดูลิงก์ข้อกำหนด →

ข้อกำหนดทางเทคนิคของรูปแบบไฟล์คลังข้อมูล RAR 5.0

Eugene Roshal / Win.rar GmbH

ดูลิงก์ข้อกำหนด →

ISO 9660:1988 การประมวลผลข้อมูล - โครงสร้างวอลุ่มและไฟล์ของซีดีรอมสำหรับการแลกเปลี่ยนข้อมูล

International Organization for Standardization

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบดิสก์เครื่องเสมือน (VMDK) เวอร์ชัน 5.0

VMware / Broadcom

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบอิมเมจฮาร์ดดิสก์เสมือน (VHD)

Microsoft Corporation

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบอิมเมจดิสก์สากล Apple Disk Image (DMG)

Apple Inc.

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ Mobipocket และโครงสร้างการบรรจุแบบเปิด

Mobipocket / Amazon

ดูลิงก์ข้อกำหนด →

แนวทางปฏิบัติในการเผยแพร่ Amazon Kindle Format 8 (AZW3)

Amazon Kindle Direct Publishing

ดูลิงก์ข้อกำหนด →

ข้อกำหนดอีบุ๊ก XML FictionBook 2.0 (FB2)

FictionBook Open Source Project

ดูลิงก์ข้อกำหนด →

WebVTT: รูปแบบแทร็กข้อความวิดีโอบบนเว็บ

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดคำบรรยาย Matroska / SubRip (SRT)

Matroska Specification Project

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบสคริปต์ Advanced SubStation Alpha v4.00+

Doom9 / Aegisub Community

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Khronos glTF 2.0 (GL Transmission Format)

Khronos Group 3D Formats Working Group

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์โพลีกอน (PLY)

Stanford University Computer Graphics Laboratory

ดูลิงก์ข้อกำหนด →

ข้อกำหนดชุดพัฒนาซอฟต์แวร์และแอสเซทไบนารี Autodesk FBX

Autodesk Developer Network

ดูลิงก์ข้อกำหนด →

รูปแบบไฟล์ฐานข้อมูล SQLite

SQLite Development Team

ดูลิงก์ข้อกำหนด →

ISO/IEC 9075: เทคโนโลยีสารสนเทศ - ภาษาฐานข้อมูล - SQL

International Organization for Standardization

ดูลิงก์ข้อกำหนด →

ข้อกำหนด TIFF ฉบับปรับปรุง 6.0

Adobe Systems Incorporated

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์บิตแมป Microsoft Windows (BMP)

Microsoft Developer Network

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ Truevision TGA เวอร์ชัน 2.0

Truevision / AT&T

ดูลิงก์ข้อกำหนด →

คู่มือการเขียนโปรแกรมและข้อกำหนดรูปแบบ Microsoft DirectDraw Surface (DDS)

Microsoft DirectX Graphics Documentation

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Adobe Digital Negative (DNG) เวอร์ชัน 1.6.0.0

Adobe Systems Incorporated

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ RAW ของกล้องดิจิทัล Canon (CR2)

Canon Inc. / ExifTool Metadata Project

ดูลิงก์ข้อกำหนด →

ข้อมูลอ้างอิงทางเทคนิค Nikon Electronic Format (NEF)

Nikon Corporation / LibRaw Project

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Sony Alpha RAW (ARW) และข้อมูลอ้างอิงเมทาเดตา

Sony Corporation / ExifTool Project

ดูลิงก์ข้อกำหนด →

RFC 4648: การเข้ารหัสข้อมูล Base16, Base32 และ Base64

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ออบเจกต์ฐานสิบหก (Intel HEX)

Intel Corporation

ดูลิงก์ข้อกำหนด →

RFC 7946: รูปแบบ GeoJSON

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดมาตรฐาน OGC KML 2.3

Open Geospatial Consortium (OGC)

ดูลิงก์ข้อกำหนด →

GPX: สคีมา GPS Exchange Format 1.1

Topografix

ดูลิงก์ข้อกำหนด →

เอกสารทางเทคนิคคำอธิบาย ESRI Shapefile

Environmental Systems Research Institute (ESRI)

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ Adobe Swatch Exchange (ASE)

Adobe Systems Developer Support

ดูลิงก์ข้อกำหนด →

เอกสารประกอบรูปแบบจานสี GIMP (GPL)

GNU Image Manipulation Program (GIMP) Project

ดูลิงก์ข้อกำหนด →

ข้อกำหนด CSS Color Module Level 4

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

ข้อกำหนด YAML Ain't Markup Language (YAML) เวอร์ชัน 1.2

YAML.org Working Group

ดูลิงก์ข้อกำหนด →

TOML: ข้อกำหนดภาษาขั้นต่ำที่ชัดเจนของ Tom เวอร์ชัน v1.0.0

TOML Open Source Project

ดูลิงก์ข้อกำหนด →

ภาษา Extensible Markup Language (XML) 1.0 (พิมพ์ครั้งที่ห้า)

World Wide Web Consortium (W3C)

ดูลิงก์ข้อกำหนด →

คำจำกัดความมาตรฐาน Flexible Image Transport System (FITS) 4.0

International Astronomical Union (IAU) FITS Working Group

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ HDF5 เวอร์ชัน 3.0

The HDF Group

ดูลิงก์ข้อกำหนด →

โครงสร้างและข้อกำหนดรูปแบบไฟล์ NetCDF

UCAR Unidata Program Center

ดูลิงก์ข้อกำหนด →

การแทนลำดับ NCBI FASTA และรูปแบบฐานข้อมูล Blast

National Center for Biotechnology Information (NCBI)

ดูลิงก์ข้อกำหนด →

คู่มือเนื้อหาฐานข้อมูลโปรตีน: คำอธิบายรูปแบบรายการพิกัดอะตอม v3.30

Worldwide Protein Data Bank (wwPDB)

ดูลิงก์ข้อกำหนด →

RFC 7932: รูปแบบข้อมูลบีบอัด Brotli

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 8878: การบีบอัด Zstandard และประเภท 'application/zstd'

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 1951: ข้อกำหนดรูปแบบข้อมูลบีบอัด DEFLATE เวอร์ชัน 1.3

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

คำอธิบายรูปแบบเฟรม LZ4

Yann Collet / LZ4 Project

ดูลิงก์ข้อกำหนด →

RFC 7468: การเข้ารหัสข้อความของโครงสร้าง PKIX, PKCS และ CMS (PEM)

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 5280: โปรไฟล์ใบรับรองโครงสร้างพื้นฐานกุญแจสาธารณะ Internet X.509

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 7292: PKCS #12: ไวยากรณ์การแลกเปลี่ยนข้อมูลส่วนบุคคล v1.1

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 5322: รูปแบบข้อความอินเทอร์เน็ต

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 6350: ข้อกำหนดรูปแบบ vCard (vCard v4.0)

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

RFC 5545: ข้อกำหนดวัตถุหลักการจัดปฏิทินและการนัดหมายทางอินเทอร์เน็ต (iCalendar)

Internet Engineering Task Force (IETF)

ดูลิงก์ข้อกำหนด →

MS-OXMSG: รูปแบบไฟล์รายการ Outlook (.msg)

Microsoft Corporation

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบอิมเมจ QEMU Copy-On-Write (QCOW2)

QEMU Open Source Project

ดูลิงก์ข้อกำหนด →

สถาปัตยกรรมทางเทคนิคการสำรองข้อมูลและการกู้คืนข้อมูล Microsoft SQL Server

Microsoft Corporation

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบ hOCR 1.2 (มาตรฐานการแทนข้อมูล OCR)

hOCR Specification Working Group

ดูลิงก์ข้อกำหนด →

สถาปัตยกรรมเอนจิ้น OCR แบบโอเพนซอร์ส Tesseract และการวิเคราะห์เค้าโครงหน้า

Tesseract OCR Open Source Project / Google

ดูลิงก์ข้อกำหนด →

ข้อกำหนด APNG (Animated Portable Network Graphics)

Mozilla Developer Network (MDN) / W3C

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบแอนิเมชัน Lottie

LottieFiles / Airbnb

ดูลิงก์ข้อกำหนด →

ISO/IEC 14496-3: เทคโนโลยีสารสนเทศ - การเข้ารหัสวัตถุภาพและเสียง - ส่วนที่ 3: เสียง (AAC)

ISO/IEC JTC 1/SC 29

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบ Free Lossless Audio Codec (FLAC)

Xiph.Org Foundation

ดูลิงก์ข้อกำหนด →

ข้อกำหนดโอเพนซอร์ส Apple Lossless Audio Codec (ALAC)

Apple Inc.

ดูลิงก์ข้อกำหนด →

ข้อกำหนด Audio Interchange File Format (AIFF) v1.3

Apple Computer, Inc.

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบเสียง Direct Stream Digital (DSD / DSF)

Sony Corporation / Philips

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบเสียงไม่สูญเสียข้อมูล Monkey's Audio (.ape)

Monkey's Audio / Matthew T. Ashland

ดูลิงก์ข้อกำหนด →

[MS-EMF]: Enhanced Metafile Format

Microsoft Corporation

ดูลิงก์ข้อกำหนด →

[MS-WMF]: Windows Metafile Format

Microsoft Corporation

ดูลิงก์ข้อกำหนด →

Adobe Photoshop File Formats Specification

Adobe Systems Inc.

ดูลิงก์ข้อกำหนด →

Canon Camera Image File Format (CIFF) Specification (CRW)

Canon Inc. / ExifTool Project

ดูลิงก์ข้อกำหนด →

Canon Digital Camera RAW File Format Specification (CR3 / CRX ISOBMFF)

Canon Inc. / ExifTool Metadata Project

ดูลิงก์ข้อกำหนด →

Fujifilm RAW Format (RAF) Technical Specification

Fujifilm Corporation / ExifTool Project

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงรูปแบบ RAW สำหรับกล้องดิจิทัลมืออาชีพของ Kodak (DCR / KDC / K25)

Eastman Kodak Company / ExifTool Project

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงทางเทคนิครูปแบบ RAW ของกล้อง Leica (RWL / DNG)

Leica Camera AG / ExifTool Project

ดูลิงก์ข้อกำหนด →

คำอธิบายรูปแบบภาพ LibRaw RAW และกล้องที่รองรับ

LibRaw LLC

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงทางเทคนิครูปแบบ RAW ของ Olympus / OM Digital Solutions (ORF)

OM Digital Solutions / ExifTool Project

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงทางเทคนิค Panasonic Lumix RAW (RW2)

Panasonic Corporation / ExifTool Project

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงรูปแบบ Pentax Electronic File (PEF / PTX)

Ricoh Imaging Company / ExifTool Project

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ QuickTime

Apple Inc.

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงทางเทคนิครูปแบบ Samsung NX RAW (SRW)

Samsung Electronics / ExifTool Project

ดูลิงก์ข้อกำหนด →

คู่มืออ้างอิงทางเทคนิครูปแบบ RAW เซ็นเซอร์ภาพ Sigma Foveon X3 Direct (X3F)

Sigma Corporation / ExifTool Project

ดูลิงก์ข้อกำหนด →

ข้อกำหนดรูปแบบไฟล์ Truevision Targa เวอร์ชัน 2.0

Truevision Inc.

ดูลิงก์ข้อกำหนด →

คู่มือทางเทคนิค Paintbrush ของ ZSoft Corporation

ZSoft Corporation

ดูลิงก์ข้อกำหนด →