Güvenlik Sertifikaları: PEM, DER ve PKCS#12
Base64 ASCII zırhlı kodlama, ikili DER sertifikaları ve özel anahtar kapsayıcıları.
Dosyaların WebAssembly ve HTML5 API'leri kullanılarak doğrudan tarayıcında işlenir. Cihazından asla ayrılmaz; bu nedenle sunucuya dosya yüklenmez ve üçüncü taraflarda dosya saklanmaz.
Kendi cihazında hemen dönüştürmeye başla - yükleme bekleme, indirme kuyruğu veya uzak sunucu kaynaklı hız kısıtlaması yok.
Hesap açmadan, bir plan için ödeme yapmadan veya yapay dosya boyutu sınırına takılmadan mevcut tüm araçları kullan. Tarayıcının ve cihazının kaldırabildiği kadar sık dönüştür.
Biçim karşılaştırması ve teknik özellikler
| Çıktı biçimi | MIME Türü | Teknik belirtim | Tür |
|---|---|---|---|
| PEM Sertifikası | application/x-pem-file | RFC-7468-PEM | Base64 Korumalı Sertifika |
| CRT Sertifikası | application/x-x509-ca-cert | RFC-5280-X509 | X.509 Genel Sertifikası |
| CER Sertifikası | application/pkix-cert | RFC-5280-X509 | X.509 Güvenlik Sertifikası |
| DER İkilisi | application/x-x509-ca-cert | RFC-5280-X509 | ASN.1 İkili Sertifikası |
| P12 PKCS #12 Paketi | application/x-pkcs12 | RFC-7292-PKCS12 | Şifrelenmiş Sertifika Arşivi |
| PFX Paketi | application/x-pkcs12 | RFC-7292-PKCS12 | Microsoft Kişisel Değişim Dosyası |
Teknik Özellikler ve Kodek Ayrıntıları
PEM ile DER Karşılaştırması: Metin ve İkili
DER, SSL/TLS sertifikasının ikili ASN.1 kodlamasıdır. PEM, bu ikili verinin '-----BEGIN CERTIFICATE-----' gibi başlıklarla Base64 metnine dönüştürülmüş hâlidir. Böylece sertifikayı web sunucularına ve metin yapılandırmalarına kopyalayıp yapıştırabilirsin.
PKCS#12 (.pfx / .p12): Anahtar ve Sertifikayı Birlikte Paketleme
PEM sertifikası yalnızca açık sertifika bilgisini içerir. Sertifikaları Windows sunucuları veya Java anahtar depoları arasında taşırken PKCS#12; açık sertifikayı, sertifika güven zincirinin tamamını ve şifrelenmiş özel anahtarı tek bir parola korumalı dosyada toplar.
Harici sunuculara 0 bayt yüklendi. Tüm işlemler tarayıcındaki korumalı alanda (sandbox) yerel olarak gerçekleştirildi.