Akış Sıkıştırma: GZIP, BZIP2 ve ZSTD
Tek dosyalı akış sıkıştırma algoritmaları ve web aktarım kodekleri.
Dosyaların WebAssembly ve HTML5 API'leri kullanılarak doğrudan tarayıcında işlenir. Cihazından asla ayrılmaz; bu nedenle sunucuya dosya yüklenmez ve üçüncü taraflarda dosya saklanmaz.
Kendi cihazında hemen dönüştürmeye başla - yükleme bekleme, indirme kuyruğu veya uzak sunucu kaynaklı hız kısıtlaması yok.
Hesap açmadan, bir plan için ödeme yapmadan veya yapay dosya boyutu sınırına takılmadan mevcut tüm araçları kullan. Tarayıcının ve cihazının kaldırabildiği kadar sık dönüştür.
Biçim karşılaştırması ve teknik özellikler
| Çıktı biçimi | MIME Türü | Teknik belirtim | Tür |
|---|---|---|---|
| GZ IP Akışı | application/gzip | RFC-1952-GZIP | GNU Zip DEFLATE Akışı |
| BR otli Akışı | application/x-brotli | RFC-7932-BROTLI | Brotli Web Sıkıştırma Akışı |
| ZST andard Akışı | application/zstd | RFC-8878-ZSTD | Gerçek Zamanlı Zstandard Çerçevesi |
| DEFLATE Ham | application/octet-stream | RFC-1951-DEFLATE | Ham DEFLATE akışı |
| LZ4 Akışı | application/x-lz4 | LZ4-FRAME-SPEC | Ultra Hızlı LZ4 Bayt Çerçevesi |
| GZ IP Arşivi | application/gzip | RFC-1952-GZIP | DEFLATE ile Sıkıştırılmış Tek Dosyalı Arşiv |
| ZIP Arşivi | application/zip | ISO-IEC-29500 | Standart Sıkıştırılmış Arşiv |
Teknik Özellikler ve Kodek Ayrıntıları
Sıkıştırma Codec'leri ile Çok Dosyalı Arşivler Arasındaki Farklar
Yaygın bir yanlış anlama, GZIP (.gz) formatının bir ZIP dosyası gibi olduğudur. GZIP yalnızca tek bir dosyayı veya akışı sıkıştırır. Linux'ta tüm bir klasörü sıkıştırmak için araçlar öncelikle klasörü TAR kullanarak tek bir dosyada birleştirir ve ardından bu dosyayı GZIP ile sıkıştırır (.tar.gz).
Zstandard (ZSTD): Yapılandırılabilir sıkıştırma
Zstandard, hız ve sıkıştırma oranı arasında ayarlanabilir denge sunan kayıpsız bir sıkıştırma biçimidir. Aktarım hızı veriye, seviyeye, uygulamaya ve donanıma bağlıdır; performansı tahmin etmeden önce iş yükünü ölçün.
Harici sunuculara 0 bayt yüklendi. Tüm işlemler tarayıcındaki korumalı alanda (sandbox) yerel olarak gerçekleştirildi.