Файли електронної пошти: структури EML, MSG і MBOX
Межі повідомлень MIME, заголовки електронної пошти та перенесення між поштовими клієнтами.
Файли обробляються локально у вашому браузері за допомогою WebAssembly та HTML5 API. Вони ніколи не залишають ваш пристрій, тому немає завантажень на сервер чи стороннього зберігання файлів.
Починайте конвертацію негайно на своєму пристрої - без очікування передавання файлів, черг на завантаження чи обмежень віддаленого сервера.
Використовуйте будь-який доступний інструмент без створення облікового запису, оплати тарифу чи штучних обмежень на розмір файлу. Конвертуйте стільки, скільки дозволяють ваш браузер і пристрій.
Порівняння форматів та технічні характеристики
| Формат виводу | MIME-тип | Специфікація | Тип |
|---|---|---|---|
| EML Електронна пошта RFC 822 | message/rfc822 | RFC-5322-EMAIL | Стандартний файл повідомлення електронної пошти |
| MSG Outlook | application/vnd.ms-outlook | MS-OXMSG-SPEC | Елемент Microsoft Outlook |
| MBOX Архів | application/mbox | RFC-5322-EMAIL | Файл об'єднання поштових скриньок |
| VCF Контакт vCard | text/vcard | RFC-6350-VCARD | Електронна візитна картка |
| ICS Календар iCalendar | text/calendar | RFC-5545-ICAL | Подія календаря та планування |
| PDF Документ | application/pdf | ISO-32000-2 | Портативний формат документів |
| HTML Вихідний код | text/html | RFC-5322-EMAIL | Документ із розміткою гіпертексту |
| TXT Текстовий транскрипт | text/plain | RFC-4180-CSV | Неформатований текстовий транскрипт субтитрів |
| CSV Таблиця | text/csv | RFC-4180-CSV | Значення, розділені комами |
Технічні специфікації та розбір кодеків
EML проти MSG: відкритий стандарт і Outlook
EML зазвичай зберігає повідомлення за форматом Internet Message Format і правилами MIME; поштові клієнти можуть також використовувати власні формати зберігання. MSG : формат повідомлень Microsoft Outlook. Перетворення MSG на EML може полегшити відкриття повідомлення в іншому ПЗ, але відображення та підтримка метаданих залежать від програми.
Витягування вкладень та збереження заголовків
Електронний лист може містити заголовки, частини MIME та вкладення. Експорт EML у PDF може створити читабельну копію, але сам по собі не зберігає всю початкову структуру повідомлення й не доводить автентичність або юридичну придатність до аудиту. Збережіть оригінал і дотримуйтеся вимог до зберігання записів у вашому процесі.
Жодного байта не передано на зовнішні сервери. Уся обробка відбувалася локально в ізольованому середовищі браузера.