File2File.app

Конвертуйте будь-який файл у своєму браузері

Конвертуйте файли миттєво у своєму браузері - без передавання на сервер, черг, лімітів і платних тарифів.

Перетягніть файл, щоб дізнатися, що з ним можна зробити

Файл визначається на вашому пристрої за першими байтами. Нічого не передається на сервер.

Інструменти конвертації файлів

250 пар форматів у 28 підібраних групах

Інструменти стиснення файлів

Оптимізація файлів у браузері без передавання на сервер

Розширені інструменти PDF у браузері

Обертайте, додавайте водяні знаки й номери сторінок та розділяйте багатосторінкові документи PDF. Обробка повністю конфіденційна і відбувається на пристрої. Приватно - файли ніколи не залишають ваш пристрій.

Енциклопедія форматів і технічні специфікації

Сигнатури заголовків на байтовому рівні, бінарні специфікації, стандарти ISO/RFC та історія

Документ PDF

.pdf

ISO 32000-1 (2008) / ISO 32000-2 (2020)

Зображення PNG

.png

W3C Recommendation (1996) / ISO/IEC 15948:2004

Зображення JPEG

.jpg

ISO/IEC 10918-1 / ITU-T T.81

Зображення WebP

.webp

RFC 6386 / RIFF Container Specification

Зображення AVIF

.avif

ISO/IEC 23000-22 (MIAF) / AOMedia Specification

Векторне зображення SVG

.svg

W3C Recommendation (SVG 1.1 / SVG 2)

Документ Word

.docx

ECMA-376 / ISO/IEC 29500

Архів ZIP

.zip

PKWARE APPNOTE / ISO/IEC 21320-1

Анімований GIF

.gif

CompuServe GIF87a / GIF89a Specification

Дані JSON

.json

RFC 8259 / ECMA-404 / ISO/IEC 21778

Таблиця CSV

.csv

RFC 4180 / IETF

Конфігурація XML

.xml

W3C Recommendation (XML 1.0 Fifth Edition)

Аудіо AAC

.aac

ISO/IEC 13818-7 / ISO/IEC 14496-3

Аудіо AIFF

.aiff

Apple / Electronic Arts IFF 85 Standard

Apple Lossless

.alac

Apple Open Source / ISO 14496-12

Monkey's Audio

.ape

Matthew T. Ashland Open Specification

Аудіо FLAC

.flac

Xiph.Org Open Standard / IETF Draft

Аудіо M4A

.m4a

ISO/IEC 14496-14 (MPEG-4 Part 14)

Аудіокнига M4B

.m4b

Apple Inc. / ISO/IEC 14496-14

Аудіо MIDI

.mid

MIDI Manufacturers Association (MMA) / AMEI

Аудіо MP3

.mp3

ISO/IEC 11172-3 / ISO/IEC 13818-3

OGG Vorbis

.ogg

Xiph.Org Foundation / IETF RFC 3533 & RFC 5334

Аудіо Opus

.opus

IETF RFC 6716

Аудіо WAV

.wav

Microsoft & IBM Resource Interchange File Format (RIFF)

Відео 3GP

.3gp

3GPP TS 26.244 / ISO 14496-12

Відео AVI

.avi

Microsoft RIFF Specification / OpenDML Extension

Відео Flash

.flv

Adobe Systems Flash Video File Format Specification

Відео Matroska

.mkv

Matroska Open Standard / IETF Working Group Draft

QuickTime MOV

.mov

Apple Computer Inc. QuickTime Specification

Відео MP4

.mp4

ISO/IEC 14496-14:2003

Відео WebM

.webm

WebM Project / IETF Cellar Working Group

Sony ARW

.arw

TIFF/EP (ISO 12234-2) extension

Canon CR2

.cr2

TIFF/EP (ISO 12234-2) derivative

Canon CR3

.cr3

ISO/IEC 14496-12 (ISO Base Media File Format)

Canon CRW

.crw

Camera Image File Format (CIFF)

Kodak DCR

.dcr

TIFF-based proprietary format

Kodak DCS

.dcs

TIFF-based Kodak proprietary

Adobe DNG

.dng

ISO 12234-2 compatible / Adobe Open Specification

Kodak DRF

.drf

TIFF-based Kodak proprietary

Kodak K25

.k25

TIFF-based Kodak proprietary

Kodak KDC

.kdc

TIFF-based Kodak proprietary

Nikon NEF

.nef

TIFF/EP (ISO 12234-2) extension

Nikon NRW

.nrw

TIFF/EP (ISO 12234-2) derivative

Olympus ORF

.orf

TIFF-based proprietary format

Pentax PEF

.pef

TIFF/EP (ISO 12234-2) derivative

Pentax PTX

.ptx

TIFF-based proprietary format

Fujifilm RAF

.raf

Fujifilm proprietary container

RAW-формат камери

.raw

TIFF-based / Panasonic proprietary

Panasonic RW2

.rw2

Panasonic proprietary format

Leica RWL

.rwl

TIFF-based Leica raw format; camera support varies by model

Sony SR2

.sr2

TIFF-based proprietary format

Sony SRF

.srf

TIFF-based proprietary format

Samsung SRW

.srw

TIFF-based proprietary format

Sigma X3F

.x3f

Foveon proprietary specification

Анімований PNG

.apng

W3C Community Group Report (2021) / Mozilla Extension

Растрове зображення Windows

.bmp

Microsoft Windows Device-Independent Bitmap (DIB) Architecture

Курсор Windows

.cur

Microsoft Windows Resource Specification

Креслення DXF

.dxf

Autodesk Open CAD Specification

Розширений метафайл

.emf

[MS-EMF]: Enhanced Metafile Format Specification

Encapsulated PostScript

.eps

Adobe Encapsulated PostScript File Format Specification v3.0

Зображення OpenEXR

.exr

Academy Software Foundation (ASWF) Open Standard

Radiance HDR

.hdr

Radiance Synthetic Imaging System Standard

Фотографія HEIC

.heic

ISO/IEC 23008-12 (HEIF standard)

Іконка Windows

.ico

Microsoft Windows Icon Resource Specification

Зображення JFIF

.jfif

ITU-T T.871 / ISO/IEC 10918-5

Portable Bitmap

.pbm

Netpbm Library Standard

ZSoft PCX

.pcx

ZSoft PC Paintbrush Technical Reference Manual

Portable Graymap

.pgm

Netpbm Library Standard

Portable Pixmap

.ppm

Netpbm Library Standard

Великий документ Photoshop

.psb

Adobe Photoshop File Format Specification (Version 2)

Документ Photoshop

.psd

Adobe Photoshop File Format Specification (Version 1)

Truevision TGA

.tga

Truevision TGA File Format Specification v2.0

Зображення TIFF

.tiff

TIFF Revision 6.0 (Adobe Systems)

Метафайл Windows

.wmf

[MS-WMF]: Windows Metafile Format Specification

Архів 7-Zip

.7z

7-Zip Open Architecture Specification

Потік Brotli

.br

IETF RFC 7932

Архів BZIP2

.bz2

Bzip2 Open Source Standard

Сирий DEFLATE

.deflate

IETF RFC 1951 / RFC 1950 (zlib)

Архів GZIP

.gz

IETF RFC 1952

Архів RAR

.rar

RAR5 Architecture Specification

Архів TAR

.tar

POSIX.1-1988 (ustar) / POSIX.1-2001 (pax)

Архів Tar Gzip

.tar.gz

POSIX.1 ustar (RFC 1952 gzip wrapped)

Потік Zstandard

.zst

IETF RFC 8878

Формат Kindle 8

.azw3

Amazon Proprietary KF8 Specification

Електронна книга EPUB

.epub

W3C EPUB 3.3 Recommendation

Документ FictionBook

.fb2

FictionBook Open XML Specification

Вихідний код HTML

.html

WHATWG HTML Living Standard / W3C Recommendation

Параметри INI

.ini

De facto industry configuration standard

Документ Markdown

.md

CommonMark Specification / GitHub Flavored Markdown (GFM)

Електронна книга Mobipocket

.mobi

Mobipocket / Amazon Legacy Specification

Protein Data Bank

.pdb

Palm OS File System Architecture Specification

SQL-дамп

.sql

ISO/IEC 9075:2023 / ANSI SQL Standard

Конфігурація TOML

.toml

TOML v1.0.0 Specification

Текстовий транскрипт

.txt

ISO/IEC 10646 / Unicode Standard / IETF RFC 2046

Конфігурація YAML

.yaml

YAML 1.2.2 Specification

Dotenv

.env

The Twelve-Factor App Specification / Dotenv Standard

Двійковий формат glTF

.glb

ISO/IEC 12113:2022 / Khronos Open Standard

Дані glTF у форматі JSON

.gltf

ISO/IEC 12113:2022 / Khronos Open Standard

Wavefront OBJ

.obj

Wavefront Advanced Visualizer Specification

Полігональний формат PLY

.ply

Stanford University Computer Graphics Laboratory Standard

Стереолітографія (STL)

.stl

3D Systems Stereolithography Specification

Файл хімічних координат

.xyz

De facto computational chemistry standard

Шрифт OpenType

.otf

ISO/IEC 14496-22 (Open Font Format) / OpenType 1.9

Шрифт TrueType

.ttf

ISO/IEC 14496-22 / Apple TrueType Reference Manual

Web Open Font Format

.woff

W3C Recommendation (2012)

Шрифт WOFF2

.woff2

W3C Recommendation (2018)

Advanced SubStation Alpha

.ass

Advanced SubStation Alpha v4.00+ Specification

Субтитри SubRip

.srt

De facto global subtitle standard

Субтитри MicroDVD

.sub

MicroDVD File Specification

Субтитри WebVTT

.vtt

W3C WebVTT Recommendation

Сертифікат CER

.cer

ITU-T X.509 / IETF RFC 5280

Сертифікат CRT

.crt

ITU-T X.509 / IETF RFC 5280

Двійковий файл DER

.der

ITU-T Recommendation X.690

Пакет PKCS #12

.p12

IETF RFC 7292 / PKCS #12 v1.1

Сертифікат PEM

.pem

IETF RFC 7468 / RFC 1421

Електронна пошта RFC 822

.eml

IETF RFC 5322 / RFC 2045 (MIME)

Архів MBOX

.mbox

IETF RFC 4155

Outlook MSG

.msg

[MS-OXMSG]: Outlook Item (.msg) File Format

Контакт vCard

.vcf

IETF RFC 6350 (vCard v4.0)

Послідовність FASTA

.fasta

Widely used bioinformatics sequence format

Астрономічні дані FITS

.fits

IAU FITS Standard v4.0

Файл GenBank

.gb

NCBI GenBank Release Specification

Набір даних HDF5

.hdf5

The HDF Group Open Standard Specification

Сітка NetCDF

.nc

OGC NetCDF Core Standard / NASA ESDS Standard

GeoJSON

.geojson

IETF RFC 7946

Google KML

.kml

OGC KML 2.3 Standard

GPS-трек GPX

.gpx

Topografix GPX 1.1 Specification

Резервна копія бази даних

.bak

Microsoft SQL Server Backup Specification / Generic Backup

Образ диска Apple

.dmg

Apple Universal Disk Image Format (UDIF)

Образ диска ISO 9660

.iso

ISO 9660:1988 / ECMA-119 / UDF (Universal Disk Format)

Образ QEMU QCOW2

.qcow2

QEMU QCOW2 Image Format Specification

Віртуальний жорсткий диск

.vhd

Microsoft Virtual Hard Disk Image Format Specification

Чому варто обрати File2File.app?

Конфіденційність за замовчуванням

Файли обробляються локально у вашому браузері за допомогою WebAssembly та HTML5 API. Вони ніколи не залишають ваш пристрій, тому немає завантажень на сервер чи стороннього зберігання файлів.

Жодних черг. Жодних обмежень швидкості.

Починайте конвертацію негайно на своєму пристрої - без очікування передавання файлів, черг на завантаження чи обмежень віддаленого сервера.

Безкоштовний та необмежений доступ

Використовуйте будь-який доступний інструмент без створення облікового запису, оплати тарифу чи штучних обмежень на розмір файлу. Конвертуйте стільки, скільки дозволяють ваш браузер і пристрій.