Стиснення потоків: GZIP, BZIP2 та ZSTD
Алгоритми стиснення окремих файлів і потоків та кодеки для передавання даних у вебі.
Файли обробляються локально у вашому браузері за допомогою WebAssembly та HTML5 API. Вони ніколи не залишають ваш пристрій, тому немає завантажень на сервер чи стороннього зберігання файлів.
Починайте конвертацію негайно на своєму пристрої - без очікування передавання файлів, черг на завантаження чи обмежень віддаленого сервера.
Використовуйте будь-який доступний інструмент без створення облікового запису, оплати тарифу чи штучних обмежень на розмір файлу. Конвертуйте стільки, скільки дозволяють ваш браузер і пристрій.
Порівняння форматів та технічні характеристики
| Формат виводу | MIME-тип | Специфікація | Тип |
|---|---|---|---|
| GZ Потік GZIP | application/gzip | RFC-1952-GZIP | Потік стиснення GNU Zip DEFLATE |
| BR Потік Brotli | application/x-brotli | RFC-7932-BROTLI | Потік веб-стиснення Brotli |
| ZST Потік Zstandard | application/zstd | RFC-8878-ZSTD | Фрейм реального часу Zstandard |
| DEFLATE Сирий | application/octet-stream | RFC-1951-DEFLATE | Сирий потік DEFLATE |
| LZ4 Потік | application/x-lz4 | LZ4-FRAME-SPEC | Ультрашвидкий байтовий фрейм LZ4 |
| GZ Архів GZIP | application/gzip | RFC-1952-GZIP | Однофайловий архів, стиснений алгоритмом DEFLATE |
| ZIP Архів | application/zip | ISO-IEC-29500 | Стандартний стиснений архів |
Технічні специфікації та розбір кодеків
Кодеки стиснення проти багатофайлових архівів
Поширеною помилкою є думка, що GZIP (.gz) схожий на файл ZIP. GZIP стискає лише один файл або потік. Щоб стиснути цілу папку в Linux, інструменти спочатку об'єднують її в єдиний файл за допомогою TAR, а потім стискають цей файл за допомогою GZIP (.tar.gz).
Zstandard (ZSTD): Налаштовуване стиснення
Zstandard : формат стиснення без втрат із налаштовуваним компромісом між швидкістю та ступенем стиснення. Пропускна здатність залежить від даних, рівня, реалізації й обладнання; виміряйте навантаження перед оцінкою продуктивності.
Жодного байта не передано на зовнішні сервери. Уся обробка відбувалася локально в ізольованому середовищі браузера.