حوّل أي ملف في متصفحك
حول ملفاتك فوراً في متصفحك - بلا رفع، بلا قوائم انتظار، بلا حدود، وبلا خطط مدفوعة.
أفلت ملفًا لمعرفة الخيارات المتاحة له
يُحدَّد نوع الملف على جهازك من بايتاته الأولى. لا يتم رفع أي شيء.
أدوات تحويل الملفات
250 زوج تنسيق عبر 28 مجموعة تنسيقات منتقاة
أدوات ضغط الملفات
تحسين محلي داخل المتصفح بدون أي رفع إلى الخادم
أدوات PDF متقدمة داخل المتصفح
دوّر الصفحات، وأضف العلامات المائية وأرقام الصفحات، وقسّم مستندات PDF متعددة الصفحات، مع معالجة محلية خاصة بنسبة على جهاز العميل. خاص - لا تغادر الملفات جهازك أبدًا.
موسوعة التنسيقات والمواصفات التقنية
تواقيع الترويسات على مستوى البايت، المواصفات الثنائية، معايير ISO/RFC، والتاريخ
مستند PDF
.pdfISO 32000-1 (2008) / ISO 32000-2 (2020)
صورة PNG
.pngW3C Recommendation (1996) / ISO/IEC 15948:2004
صورة JPEG
.jpgISO/IEC 10918-1 / ITU-T T.81
صورة WebP
.webpRFC 6386 / RIFF Container Specification
صورة AVIF
.avifISO/IEC 23000-22 (MIAF) / AOMedia Specification
متجه SVG
.svgW3C Recommendation (SVG 1.1 / SVG 2)
مستند Word
.docxECMA-376 / ISO/IEC 29500
أرشيف ZIP
.zipPKWARE APPNOTE / ISO/IEC 21320-1
ملف GIF متحرك
.gifCompuServe GIF87a / GIF89a Specification
بيانات JSON
.jsonRFC 8259 / ECMA-404 / ISO/IEC 21778
جدول بيانات CSV
.csvRFC 4180 / IETF
تهيئة XML
.xmlW3C Recommendation (XML 1.0 Fifth Edition)
صوت AAC
.aacISO/IEC 13818-7 / ISO/IEC 14496-3
صوت AIFF
.aiffApple / Electronic Arts IFF 85 Standard
صوت Apple Lossless
.alacApple Open Source / ISO 14496-12
صوت Monkey's Audio
.apeMatthew T. Ashland Open Specification
صوت FLAC
.flacXiph.Org Open Standard / IETF Draft
صوت M4A
.m4aISO/IEC 14496-14 (MPEG-4 Part 14)
كتاب صوتي M4B
.m4bApple Inc. / ISO/IEC 14496-14
واجهة MIDI الرقمية للآلات الموسيقية
.midMIDI Manufacturers Association (MMA) / AMEI
صوت MP3
.mp3ISO/IEC 11172-3 / ISO/IEC 13818-3
OGG Vorbis
.oggXiph.Org Foundation / IETF RFC 3533 & RFC 5334
ملف صوتي Opus
.opusIETF RFC 6716
صوت WAV
.wavMicrosoft & IBM Resource Interchange File Format (RIFF)
حاوية الوسائط المتعددة 3GPP (3GP)
.3gp3GPP TS 26.244 / ISO 14496-12
صيغة AVI للصوت والفيديو
.aviMicrosoft RIFF Specification / OpenDML Extension
حاوية فيديو Flash
.flvAdobe Systems Flash Video File Format Specification
حاوية Matroska للوسائط المتعددة
.mkvMatroska Open Standard / IETF Working Group Draft
QuickTime MOV
.movApple Computer Inc. QuickTime Specification
فيديو MP4
.mp4ISO/IEC 14496-14:2003
فيديو WebM
.webmWebM Project / IETF Cellar Working Group
ملف Sony ARW
.arwTIFF/EP (ISO 12234-2) extension
ملف Canon CR2
.cr2TIFF/EP (ISO 12234-2) derivative
Canon CR3
.cr3ISO/IEC 14496-12 (ISO Base Media File Format)
Canon CRW
.crwCamera Image File Format (CIFF)
Kodak DCR
.dcrTIFF-based proprietary format
Kodak DCS
.dcsTIFF-based Kodak proprietary
ملف Adobe DNG
.dngISO 12234-2 compatible / Adobe Open Specification
Kodak DRF
.drfTIFF-based Kodak proprietary
Kodak K25
.k25TIFF-based Kodak proprietary
Kodak KDC
.kdcTIFF-based Kodak proprietary
ملف Nikon NEF
.nefTIFF/EP (ISO 12234-2) extension
Nikon NRW
.nrwTIFF/EP (ISO 12234-2) derivative
Olympus ORF
.orfTIFF-based proprietary format
Pentax PEF
.pefTIFF/EP (ISO 12234-2) derivative
Pentax PTX
.ptxTIFF-based proprietary format
Fujifilm RAF
.rafFujifilm proprietary container
صورة RAW من الكاميرا
.rawTIFF-based / Panasonic proprietary
ملف Panasonic RW2
.rw2Panasonic proprietary format
Leica RWL
.rwlTIFF-based Leica raw format; camera support varies by model
Sony SR2
.sr2TIFF-based proprietary format
Sony SRF
.srfTIFF-based proprietary format
Samsung SRW
.srwTIFF-based proprietary format
Sigma X3F
.x3fFoveon proprietary specification
ملف PNG متحرك
.apngW3C Community Group Report (2021) / Mozilla Extension
صورة بيتماب Windows
.bmpMicrosoft Windows Device-Independent Bitmap (DIB) Architecture
مؤشر Windows
.curMicrosoft Windows Resource Specification
رسم DXF
.dxfAutodesk Open CAD Specification
ملف وسيط محسّن
.emf[MS-EMF]: Enhanced Metafile Format Specification
بوست سكريبت مغلف
.epsAdobe Encapsulated PostScript File Format Specification v3.0
صورة OpenEXR
.exrAcademy Software Foundation (ASWF) Open Standard
صورة Radiance HDR
.hdrRadiance Synthetic Imaging System Standard
صورة HEIC
.heicISO/IEC 23008-12 (HEIF standard)
أيقونة Windows
.icoMicrosoft Windows Icon Resource Specification
صورة JFIF
.jfifITU-T T.871 / ISO/IEC 10918-5
صورة نقطية محمولة
.pbmNetpbm Library Standard
ZSoft PCX
.pcxZSoft PC Paintbrush Technical Reference Manual
تدرج رمادي محمول
.pgmNetpbm Library Standard
تنسيق الصور النقطية المحمولة
.ppmNetpbm Library Standard
مستند فوتوشوب كبير
.psbAdobe Photoshop File Format Specification (Version 2)
مستند فوتوشوب
.psdAdobe Photoshop File Format Specification (Version 1)
ملف Truevision TGA
.tgaTruevision TGA File Format Specification v2.0
صورة TIFF
.tiffTIFF Revision 6.0 (Adobe Systems)
ملف رسومي وسيط من Windows
.wmf[MS-WMF]: Windows Metafile Format Specification
أرشيف 7-Zip
.7z7-Zip Open Architecture Specification
تدفق Brotli
.brIETF RFC 7932
أرشيف BZIP2
.bz2Bzip2 Open Source Standard
DEFLATE خام
.deflateIETF RFC 1951 / RFC 1950 (zlib)
أرشيف GZIP
.gzIETF RFC 1952
أرشيف RAR
.rarRAR5 Architecture Specification
أرشيف TAR
.tarPOSIX.1-1988 (ustar) / POSIX.1-2001 (pax)
أرشيف TAR مضغوط بـ Gzip
.tar.gzPOSIX.1 ustar (RFC 1952 gzip wrapped)
تدفق Zstandard
.zstIETF RFC 8878
تنسيق Kindle 8
.azw3Amazon Proprietary KF8 Specification
كتاب إلكتروني EPUB
.epubW3C EPUB 3.3 Recommendation
مستند FictionBook 2.0
.fb2FictionBook Open XML Specification
مستند HTML
.htmlWHATWG HTML Living Standard / W3C Recommendation
إعدادات INI
.iniDe facto industry configuration standard
مستند Markdown
.mdCommonMark Specification / GitHub Flavored Markdown (GFM)
كتاب إلكتروني Mobipocket
.mobiMobipocket / Amazon Legacy Specification
بنك بيانات البروتين
.pdbPalm OS File System Architecture Specification
ملف تفريغ SQL
.sqlISO/IEC 9075:2023 / ANSI SQL Standard
تهيئة TOML
.tomlTOML v1.0.0 Specification
نص عادي
.txtISO/IEC 10646 / Unicode Standard / IETF RFC 2046
تهيئة YAML
.yamlYAML 1.2.2 Specification
Dotenv
.envThe Twelve-Factor App Specification / Dotenv Standard
ملف glTF الثنائي
.glbISO/IEC 12113:2022 / Khronos Open Standard
بيانات glTF بصيغة JSON
.gltfISO/IEC 12113:2022 / Khronos Open Standard
نموذج Wavefront OBJ
.objWavefront Advanced Visualizer Specification
ملف Polygon PLY
.plyStanford University Computer Graphics Laboratory Standard
تنسيق الطباعة الحجرية المجسمة STL
.stl3D Systems Stereolithography Specification
ملف إحداثيات كيميائية
.xyzDe facto computational chemistry standard
خط OpenType
.otfISO/IEC 14496-22 (Open Font Format) / OpenType 1.9
خط TrueType
.ttfISO/IEC 14496-22 / Apple TrueType Reference Manual
تنسيق خطوط الويب المفتوحة
.woffW3C Recommendation (2012)
خط WOFF2 للويب
.woff2W3C Recommendation (2018)
ترجمة Advanced SubStation Alpha
.assAdvanced SubStation Alpha v4.00+ Specification
ترجمة SubRip
.srtDe facto global subtitle standard
ترجمة MicroDVD
.subMicroDVD File Specification
ترجمة WebVTT
.vttW3C WebVTT Recommendation
شهادة CER
.cerITU-T X.509 / IETF RFC 5280
شهادة CRT
.crtITU-T X.509 / IETF RFC 5280
ملف ثنائي DER
.derITU-T Recommendation X.690
حزمة PKCS #12
.p12IETF RFC 7292 / PKCS #12 v1.1
شهادة PEM
.pemIETF RFC 7468 / RFC 1421
بريد إلكتروني RFC 822
.emlIETF RFC 5322 / RFC 2045 (MIME)
أرشيف MBOX
.mboxIETF RFC 4155
رسالة Outlook MSG
.msg[MS-OXMSG]: Outlook Item (.msg) File Format
جهة اتصال vCard
.vcfIETF RFC 6350 (vCard v4.0)
تسلسل FASTA
.fastaWidely used bioinformatics sequence format
بيانات فلكية FITS
.fitsIAU FITS Standard v4.0
ملف GenBank
.gbNCBI GenBank Release Specification
مجموعة بيانات HDF5
.hdf5The HDF Group Open Standard Specification
شبكة NetCDF
.ncOGC NetCDF Core Standard / NASA ESDS Standard
ملف GeoJSON
.geojsonIETF RFC 7946
ملف Google KML
.kmlOGC KML 2.3 Standard
مسار GPS GPX
.gpxTopografix GPX 1.1 Specification
نسخة احتياطية لقاعدة البيانات
.bakMicrosoft SQL Server Backup Specification / Generic Backup
ملف قرص Apple
.dmgApple Universal Disk Image Format (UDIF)
صورة قرص ISO 9660
.isoISO 9660:1988 / ECMA-119 / UDF (Universal Disk Format)
صورة QEMU QCOW2
.qcow2QEMU QCOW2 Image Format Specification
قرص صلب افتراضي VHD
.vhdMicrosoft Virtual Hard Disk Image Format Specification
لماذا تختار File2File.app؟
الخصوصية جزء من التصميم
تتم معالجة الملفات محلياً في متصفحك باستخدام تقنيات WebAssembly وواجهات HTML5 البرمجية. لا تغادر ملفاتك جهازك أبداً، مما يعني عدم وجود عمليات رفع للخوادم أو تخزين للملفات لدى طرف ثالث.
بلا قوائم انتظار. بلا قيود على السرعة.
ابدأ التحويل فوراً على جهازك الخاص - دون انتظار رفع الملفات أو انتظار دور لتنزيلها، وبلا تقييد للسرعة من أي خادم بعيد.
وصول مجاني بلا حدود
استخدم كل أداة متاحة دون الحاجة إلى إنشاء حساب أو الدفع مقابل خطة أو مواجهة حدّ مصطنع لحجم الملف. حوّل الملفات بالقدر الذي يستطيع متصفحك وجهازك تحمّله.